View a markdown version of this page

Problembehandlung bei einer ServiceNow Datenquelle - Amazon Bedrock

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

Problembehandlung bei einer ServiceNow Datenquelle

Verwenden Sie diese Seite, um häufig auftretende Probleme bei der ServiceNow Authentifizierung und Synchronisierung zu diagnostizieren.

Fehler bei der Authentifizierung und beim API-Zugriff

In der folgenden Tabelle werden häufig auftretende Authentifizierungs- und API-Zugriffsfehler, ihre wahrscheinlichen Ursachen und deren Behebung beschrieben.

Authentifizierungs- und API-Zugriffsfehler
Symptom Wahrscheinliche Ursache Reparieren
Die Tabellen-API gibt HTTP 401 zurück, obwohl die Token-Anfrage erfolgreich war. Das Profil für eingehende Authentifizierung ist nicht mit der REST-API-Zugriffsrichtlinie verknüpft, oder die Richtlinie „Zugriff zulassen“ wurde dem Profil nicht hinzugefügt. Überprüfen Sie beide Seiten der Konfiguration der API-Zugriffsrichtlinie. Siehe Schritt 6: API-Zugriffsrichtlinien konfigurieren.
Die Synchronisierung ist abgeschlossen, es werden jedoch 0 gecrawlte Dokumente gemeldet. Das Dienstkonto hat statt knowledge oder die catalog Basisrolle knowledge_admin odercatalog_admin. Weisen Sie catalog_admin dem Dienstkonto knowledge_admin und zu. Siehe Schritt 3: Weisen Sie Dienstkonto-Rollen zu.
Die Token-Anfrage schlägt fehl oder der Connector kann Ihre Instance nicht erreichen. Die glide.oauth.inbound.client.credential.grant_type.enabled Systemeigenschaft ist nicht auf festgelegttrue, oder die Instanz ist von nicht erreichbar AWS. Überprüfen Sie die Systemeigenschaft und die Netzwerkkonnektivität. Siehe Schritt 1: Aktivieren Sie den Gewährungstyp für Client-Anmeldeinformationen.

Leistung synchronisieren

In der folgenden Tabelle wird ein häufig auftretendes Problem mit der Synchronisierungsleistung beschrieben und es wird beschrieben, wie es behoben werden kann.

Leistungsprobleme bei der Synchronisierung
Symptom Wahrscheinliche Ursache Reparieren
Die Synchronisierung dauert bei großen Instanzen Stunden. Da keine Katalog-ID-Filterung konfiguriert ist, durchsucht der Connector alle aktiven Katalogelemente (100.000 oder mehr auf Enterprise-Instances). Verwenden Sie serviceCatalogFilter (mitinclusionServiceCatalogSysIds) infilterConfiguration, um den Crawl auf bestimmte Servicekataloge zu beschränken. Siehe Connector-Parameter.