View a markdown version of this page

Résoudre les problèmes liés à une source ServiceNow de données - Amazon Bedrock

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Résoudre les problèmes liés à une source ServiceNow de données

Utilisez cette page pour diagnostiquer les problèmes courants liés à ServiceNow l'authentification et à la synchronisation.

Erreurs d'authentification et d'accès à l'API

Le tableau suivant décrit les erreurs d'authentification et d'accès aux API courantes, leurs causes probables et la manière de les corriger.

Erreurs d'authentification et d'accès à l'API
Symptôme Cause probable Corriger
L'API Table renvoie HTTP 401 même si la demande de jeton aboutit. Le profil d'authentification entrant n'est pas lié à la politique d'accès à l'API REST, ou la politique d'autorisation d'accès n'a pas été ajoutée au profil. Vérifiez les deux côtés de la configuration de la politique d'accès à l'API. Consultez Étape 6 : Configuration des politiques d'accès aux API.
La synchronisation est terminée mais aucun document n'a été analysé. Le compte de service a le catalog rôle de base knowledge ou au lieu de knowledge_admin oucatalog_admin. Attribuez knowledge_admin et catalog_admin au compte de service. Consultez Étape 3 : Attribuer des rôles aux comptes de service.
La demande de jeton échoue ou le connecteur ne peut pas atteindre votre instance. La propriété glide.oauth.inbound.client.credential.grant_type.enabled système n'est pas définie surtrue, ou l'instance n'est pas accessible depuis AWS. Vérifiez les propriétés du système et la connectivité réseau. Consultez Étape 1 : activer le type d'autorisation des informations d'identification du client.

Performance de synchronisation

Le tableau suivant décrit un problème de performances de synchronisation courant et explique comment le résoudre.

Problèmes de performances de synchronisation
Symptôme Cause probable Corriger
La synchronisation prend des heures sur les grandes instances. Aucun filtrage des identifiants de catalogue n'est configuré, de sorte que le connecteur analyse tous les éléments de catalogue actifs (100 000 ou plus sur les instances d'entreprise). Utilisez serviceCatalogFilter (withinclusionServiceCatalogSysIds) in filterConfiguration pour étendre l'exploration à des catalogues de services spécifiques. Consultez Paramètres du connecteur.