View a markdown version of this page

Aurora MySQL 8.4.8,2026 年 9 月 3 日 - Amazon Aurora

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Aurora MySQL 8.4.8,2026 年 9 月 3 日

版本:8.4.8

此版本的 Aurora MySQL 与 MySQL 8.4.8 兼容。有关已发生的社区变更的更多信息,请参阅 MySQL 网站上的 MySQL 8.4 发行说明。

有关 Aurora MySQL 版本 8.4 中新功能的详细信息,请参阅与 MySQL 8.4 兼容的 Aurora MySQL 版本 8.4 。有关 Aurora MySQL 版本 8.4 和版本 3 之间的区别,请参阅 Aurora MySQL 版本 3 和 Aurora MySQL 版本 8.4 的比较。有关与 MySQL 8.4 社区版的比较,请参阅亚马逊 Aurora 用户指南中的 Aurora MySQL 版本 8.4 和 MySQL 8.4 社区版的比较。

您可以执行就地主要版本升级、通过升级还原快照或使用 Amazon RDS Blue/Green 部署启动托管 blue/green 升级。您可以从任何目前支持的 Aurora MySQL 版本 3 集群升级到 Aurora MySQL 版本 8.4.8。

有关计划升级到 Aurora MySQL 版本 8.4 的信息,请参阅规划 Aurora MySQL 集群的主要版本升级。有关 Aurora MySQL 升级的一般信息,请参阅《Amazon Aurora 用户指南》中的升级 Amazon Aurora MySQL 数据库集群。

有关故障排除信息,请参阅《Amazon Aurora 用户指南》中的 Aurora MySQL 就地升级故障排除。

如果您有任何问题或疑虑,可以在社区论坛和 AWS 支持部门获得AWS 支持。有关更多信息,请参阅《Amazon Aurora 用户指南》中的维护 Aurora 数据库集群。

新特征

  • 增加了对多源二进制日志 (binlog) 复制的支持。此功能允许 Aurora MySQL 数据库集群同时复制来自多个 MySQL-compatible 源数据库的数据。每个源连接都通过专用的复制通道进行管理,该通道具有自己的接收器线程、应用器线程和中继日志。您可以使用新的每通道存储过程来配置和管理频道。有关更多信息,请参阅亚马逊 Aurora 用户指南中的在 Aurora MySQL 中使用多源复制。

  • 增加了对延迟二进制日志 (binlog) 复制的支持,在这种复制中,可以将充当二进制日志副本的 Aurora MySQL 数据库集群配置为等待指定的秒数,然后再应用从源收到的交易。延迟复制可用于防止意外的数据修改,例如意外修改DROP TABLE或DELETE语句,从而为您提供恢复窗口,以便在错误传播到副本之前识别和纠正错误。有关更多信息,请参阅 Amazon Aurora 用户指南中的配置复制延迟间隔。

  • 引入了aurora_transaction_timeout参数。此参数设置了 InnoDB 事务的最大持续时间(以秒为单位)。您可以使用此参数来帮助防止长时间运行的交易(活动或空闲)阻止 InnoDB 清除,这可能会导致性能问题。有关更多信息,请参阅亚马逊 Aurora 用户指南中的 Aurora MySQL 交易超时。

  • 增加了对 TLS 1.3 连接的后量子混合密钥交换(X25519MLKEM768 和 secp256r1mlKem768)的支持。支持后量子密钥交换的客户会自动协商抗量子共享密钥。要确认当前会话协商了哪个组,请查询Aurora_ssl_named_group状态变量。例如:SHOW STATUS LIKE 'Aurora_ssl_named_group';。

改进

以下是与 Aurora MySQL 8.4.7 相比所做的改进,请参阅 Aurora MySQL 8.4.7 发行说明。

安全修复

  • 修复了高级审计日志记录在 SQL SECURITY DEFINER 例程(存储过程、函数或触发器)中执行的 SQL 语句的用户和主机不正确的问题。这些记录显示了例程的定义用户和主机(例如'user'@'%'),而不是调用该例程的 SQL 客户端。修复后,记录会显示调用 SQL 客户端的用户和主机。

  • 修复了通过准备好的语句运行的查询可能会在 “高级审计” 日志中生成重复条目的问题。

  • 修复了在使用写入转发的SET ROLE NONE会话中无法正确清除先前处于活动状态的角色的权限的问题,写入转发可能允许在角色停用后本应被拒绝的操作。

此版本修复了以下高严重性 CVE:

此版本修复了以下中等严重性 CVE:

此版本修复了以下低严重性 CVE:

可用性改进

  • 修复了在执行时或并发操作(例如性能架构查询ALTER TABLE ... REORGANIZE PARTITIONDROP PARTITION、全文搜索优化或ADD PARTITION统计信息收集)访问同一个表时可能导致数据库实例重新启动的问题。

  • 修复了在使用ALGORITHM=INSTANT添加了列的表ALTER TABLE ... REORGANIZE PARTITION上运行查询performance_schema.data_lock_waits或同时performance_schema.data_locks运行查询时,可能会导致数据库实例重新启动的问题。

  • 修复了在处理更改子分区顺序的 ALTER TABLE ... REORGANIZE PARTITION SQL 语句时可能导致写入器实例重新启动的问题。

  • 修复了写入器实例上的 DDL 操作可能会阻止或终止读取器实例上的某些 SQL 语句的问题。受影响的语句包括对表的写入操作,例如UPDATETRUNCATE对performance_schema表的写入操作,以及对临时表的写入JOIN操作和操作。

  • 修复了在全局数据库切换操作期间数据库写入器实例在处理 SQL 语句后清理临时表时可能意外重启的问题。这种重启可能会导致更长的切换完成时间。

  • 修复了可能导致读取器数据库实例上的写入转发停止工作,需要重启读取器才能恢复写入转发的问题。当使用全局写入转发或本地写入转发时,转发的查询被取消或超时,可能会发生这种情况。

  • 修复了Aurora serverless扩展操作期间关键数据结构调整延迟可能导致 RDS 运行状况监控重启数据库实例的问题。

  • 修复了在高度并发写入操作期间由于内部计时冲突而可能导致写入器实例重启的问题。

  • 修复了启用增强二进制日志时可能导致数据库实例重新启动的问题。

  • 修复了一个错误,该错误可能会使副本短暂断开连接并重新连接到写入器,从而导致复制延迟暂时出现峰值 (AuroraReplicaLag)。

  • 修复了 Aurora 存储守护程序中的一个问题,该问题在极少数情况下可能导致数据库意外重启。

常规改进

  • 修复了启用写入转发后,aurora_replica_read_consistency设置为的读取器会话global可能无法读取最新提交的更改的问题。

  • 修复了当空间 GIS 查询在使用显式 SRID 注解声明的列上使用 Z-order 空间索引时可能导致引擎重新启动的问题。

  • 修复了启用写入转发时,写入器实例Aborted_clients上正常断开的读取器连接可能不正确地增加的问题。

  • 修复了零停机时间升级后在某些情况下无法保留连接状态的问题,这可能会导致意外行为。

  • 修复了在写入转发期间,读取器实例重启可能会在写入器实例上留下孤立转发会话的问题,而终止该会话可能导致写入器重启。

  • 通过优化修补后数据库实例与存储层之间的通信,减少了零停机时间修补 (ZDP) 期间的停机时间。

  • 修复了 Aurora MySQL 内存管理中的一个问题,即如果同时更改aurora_oom_response数据库参数值,则在内部超时期后无法可靠地禁用内存不足 (OOM) 响应操作。

  • 修复了增强版 Binlog 中的一个问题,该问题在快照还原后报告了不正确的二进制日志坐标。以前,当增强型二进制日志在源集群上运行并且某些事务被回滚时,这可能会导致二进制日志复制设置无效。

  • 修复了自动增量恢复功能中的一个问题,即分区表的自动增量值无法正确恢复,这可能会导致潜在的 DUPLICATE KEY 错误。

  • 添加了一项新 CloudWatch 指标AuroraTempTableVolumeTotalBytes,该指标报告写入器实例上内部和外部 InnoDB 临时表空间使用的总集群容量字节数。该指标报告所有活动会话中的临时表空间存储消耗。您可以使用它来监控增长趋势、识别存储密集型工作负载并设置 CloudWatch 警报。有关该 CloudWatch 指标的更多信息,请参阅亚马逊 Aurora 用户指南中的亚马逊Aurora指标。有关临时表的更多信息,请参阅 MySQL 网站上的外部临时表和内部临时表。

  • 修复了在启用写入转发的集群上发生故障转移事件后,写入转发吞吐量和延迟指标错误地报告 0 的问题。这些指标现在可以准确反映故障转移后的写入转发活动:ForwardingReplicaDMLLatencyForwardingReplicaDMLThroughput、ForwardingReplicaSelectLatency、和ForwardingReplicaSelectThroughput。

  • 修复了优化器使用预处理语句IN和参数化值来选择次优查询执行计划的性能问题。

  • 修复了在启用并行查询且哈希联接所需的内存超过限制时,可能导致使用哈希联接的查询返回错误结果的问题。

升级和迁移

  • 修复了可能导致数据库集群克隆操作需要很长时间才能完成的问题。

集成了 MySQL 社区版本错误修复

此版本基于 MySQL 8.4.8。有关更多信息,请参阅 MySQL 网站上的 MySQL 8.4 发行说明。

  • 修复了 MySQL 8.0.42 中引入的回归问题,即使用准备好的语句或存储过程插入分区表可能会失败ERROR 1748(“发现一行与给定分区集不匹配”)。当分区键列使用时,会发生这种情况DEFAULT CURRENT_TIMESTAMP。在准备时进行分区修剪会根据当前时间戳锁定分区,但在随后重新执行时,时间戳可能会映射到不同的分区。有关此修复的更多信息,请参阅 MySQL 错误网站上的 MySQL 上游错误 #119784 。