O Gateway de Arquivos do Amazon FSx não está mais disponível para novos clientes. Os clientes atuais do Gateway de arquivos do FSx podem continuar usando o serviço normalmente. Para recursos semelhantes ao Gateway de Arquivos do FSx, acesse esta publicação de blog
As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.
Solução de problemas: problemas no Gateway de Arquivos
Você pode configurar seu File Gateway para gravar entradas de log em um grupo de CloudWatch log da Amazon. Se fizer isso, você receberá notificações sobre o status de integridade do gateway e sobre erros encontrados pelo gateway. Você pode encontrar informações sobre essas notificações de erro e integridade em CloudWatch Registros.
Nas seções a seguir, é possível encontrar informações que podem ajudar a entender a causa de cada erro e notificação de integridade e como corrigir problemas.
Erro: FileMissing
O erro FileMissing é semelhante ao ObjectMissing e as etapas para resolvê-lo são idênticas. Você pode ver o erro FileMissing quando um gravador diferente do Gateway de Arquivos determinado exclui o arquivo especificado do Amazon FSx. Todos os uploads subsequentes para o Amazon FSx ou as recuperações do Amazon FSx para o objeto falham.
Para resolver um FileMissing erro
-
Salve a cópia mais recente do arquivo no sistema de arquivos local do cliente SMB (você precisará dessa cópia de arquivo na etapa 3).
-
Exclua o arquivo do Gateway de Arquivos utilizando o cliente SMB.
-
Copie a versão mais recente do arquivo que você salvou na etapa 1 Amazon FSx utilizando o cliente SMB. Faça isso por meio do Gateway de Arquivos.
Erro: FsxFileSystemAuthenticationFailure
Você pode receber um erro FsxFileSystemAuthenticationFailure quando as credenciais fornecidas ao anexar o sistema de arquivos expirarem ou seus privilégios forem revogados.
Para resolver um FsxFileSystemAuthenticationFailure erro
-
Garanta que as credenciais fornecidas no momento da anexação do sistema de arquivos do Amazon FSx ainda sejam válidas.
-
Verifique se o usuário tem todas as permissões necessárias, conforme descrito em Anexar um sistema de arquivos do Amazon FSx para Windows File Server.
Erro: FsxFileSystemConnectionFailure
Você pode receber o erro FsxFileSystemConnectionFailure quando o servidor do Amazon FSx está inacessível por meio da máquina do gateway.
Para resolver um FsxFileSystemConnectionFailure erro
-
Verifique se todas as regras de firewall e VPC permitem a conexão entre a máquina do gateway e o servidor do Amazon FSx.
-
Verifique se o servidor do Amazon FSx está em execução.
Erro: FsxFileSystemFull
Você pode receber o erro FsxFileSystemFull quando não há espaço livre suficiente em disco no sistema de arquivos do Amazon FSx.
Para resolver um FsxFileSystemFull erro
-
Aumente o espaço de armazenamento do sistema de arquivos do Amazon FSx.
Erro: GatewayClockOutOfSync
Você pode receber um GatewayClockOutOfSync erro quando o gateway detecta uma diferença de 5 minutos ou mais entre a hora do sistema local e a hora informada pelos servidores do AWS Storage Gateway. Problemas de sincronização do relógio podem afetar negativamente a conectividade entre o gateway e. AWS Se o relógio do gateway estiver fora de sincronia, poderão ocorrer I/O erros nas conexões NFS e SMB, e os usuários SMB poderão enfrentar erros de autenticação.
Para resolver um GatewayClockOutOfSync erro
-
Confira a configuração de rede entre o gateway e o servidor NTP. Para acessar mais informações sobre como sincronizar a hora da VM do gateway e atualizar a configuração do servidor NTP, consulte Configurar um servidor Network Time Protocol (NTP) para seu gateway.
Erro: InvalidFileState
Você pode receber um erro InvalidFileState quando um gravador diferente do gateway determinado modifica o arquivo especificado no compartilhamento de arquivos estabelecido. Como resultado, o estado do arquivo do gateway não corresponde ao seu estado no Amazon FSx. Todos os uploads ou recuperações subsequentes do arquivo do Amazon FSx poderão falhar.
Para resolver um InvalidFileState erro
-
Salve a cópia mais recente do arquivo no sistema de arquivos local do cliente SMB (você precisará desse arquivo para cópia na etapa 4). Se a versão do arquivo no Amazon FSx for a mais recente, baixe essa versão. Você pode fazer isso acessando diretamente o compartilhamento do Amazon FSx utilizando qualquer cliente SMB.
-
Exclua o arquivo diretamente no Amazon FSx.
-
Exclua o arquivo do gateway utilizando o cliente SMB.
-
Utilizando seu cliente SMB, copie a versão mais recente do arquivo que você salvou na etapa 1, por meio do seu Gateway de Arquivos, para o Amazon FSx.
Erro: ObjectMissing
Você pode ver o erro ObjectMissing quando um gravador diferente do Gateway de Arquivos determinado exclui o arquivo especificado do Amazon FSx. Todos os uploads subsequentes para o Amazon FSx ou as recuperações do Amazon FSx para o objeto falham.
Para resolver um ObjectMissing erro
-
Salve a cópia mais recente do arquivo no sistema de arquivos local do cliente SMB (você precisará dessa cópia de arquivo na etapa 3).
-
Exclua o arquivo do Gateway de Arquivos utilizando o cliente SMB.
-
Copie a versão mais recente do arquivo que você salvou na etapa 1 Amazon FSx utilizando o cliente SMB. Faça isso por meio do Gateway de Arquivos.
Erro: DroppedNotifications
Você pode ver um DroppedNotifications erro em vez de outros tipos esperados de entradas de CloudWatch registro quando o espaço de armazenamento livre no disco raiz do gateway for menor que 1 GB ou se mais de 100 notificações de integridade forem geradas em um intervalo de 1 minuto. Nessas circunstâncias, o gateway para de gerar notificações de CloudWatch registro detalhadas como medida de precaução.
Para resolver um DroppedNotifications erro
-
Confira a métrica
Root Disk Usagena guia Monitoramento do seu gateway no console do Storage Gateway para determinar se o espaço disponível no disco raiz está acabando. -
Aumente o tamanho do disco de armazenamento raiz do gateway se o espaço disponível for menor que 1 GB. Consulte a documentação do hipervisor da sua máquina virtual para receber instruções.
Para aumentar o tamanho do disco raiz dos gateways do Amazon EC2, consulte Solicitar modificações em seus volumes do EBS no Guia do usuário do Amazon Elastic Compute Cloud.
nota
Não é possível aumentar o tamanho do disco raiz do Dispositivo de Hardware do AWS Storage Gateway.
-
Reinicie o gateway.
Notificação: HardReboot
Você pode receber uma notificação HardReboot quando a VM do gateway é reiniciada inesperadamente. Essa reinicialização pode ocorrer devido à falta de energia, à uma falha de hardware ou a outro evento. Para gateways VMware, a reinicialização pelo vSphere High Availability Application Monitoring pode acionar esse evento.
Quando o gateway for executado nesse ambiente, verifique a presença da notificação HealthCheckFailure e consulte o log de eventos do VMware da VM.
Notificação: Reinicializar
É possível obter uma notificação de reinicialização quando a VM do gateway é reiniciada. É possível reiniciar a VM de um gateway usando o console VM Hypervisor Management ou o console do Storage Gateway. Também é possível reiniciar usando o software de gateway durante o ciclo de manutenção do gateway.
Se a hora da reinicialização estiver dentro de 10 minutos da hora de início da manutenção configurada do gateway, essa reinicialização provavelmente será uma ocorrência normal e não um sinal de algum problema. Se a reinicialização ocorreu significativamente fora da janela de manutenção, verifique se o gateway foi reiniciado manualmente.
Solução de problemas: problemas no domínio do Active Directory
O Gateway de Arquivos do FSx não gera mensagens de log específicas para problemas de domínio do Active Directory. Se você tiver problemas para associar o gateway ao domínio do Active Directory, faça o seguinte:
-
Verifique se o gateway não está tentando usar um controlador de domínio somente leitura (RODC) para ingressar no domínio.
-
Verifique se o gateway está configurado para usar os servidores DNS corretos.
Por exemplo, se você estiver tentando unir uma instância de gateway do Amazon EC2 a um Active Directory AWS gerenciado, verifique se a opção DHCP definida para sua VPC do EC2 especifica os servidores DNS do AWS Active Directory gerenciados.
Os servidores DNS configurados por meio do conjunto de opções DHCP da VPC são fornecidos para todas as instâncias do EC2 na VPC. Se quiser especificar um servidor DNS para um gateway individual, você pode fazer isso usando o console local do EC2 desse gateway.
Em relação a gateways on-premises, você especifica um servidor DNS usando o console local da VM.
-
Verifique a conectividade da rede do gateway executando os comandos a seguir no prompt de comando no console local do gateway. Substitua as variáveis destacadas pelo nome de domínio e endereços IP reais da sua implantação.
dig -dExampleDomainNamencport -dExampleDomainControllerIPAddress-p 445 ncport -dExampleDomainControllerIPAddress-p 389 -
Verifique se sua conta de serviço do Active Directory tem as permissões necessárias. Para acessar mais informações, consulte Requisitos de permissão da conta de serviço do Active Directory.
-
Verifique se o gateway se associa à unidade organizacional (UO) correta.
A adesão a um domínio cria uma conta de computador do Active Directory no contêiner de computadores padrão (que não é uma OU), usando a ID do gateway do gateway como nome da conta (por exemplo, SGW-1234ADE). Não é possível personalizar o nome dessa conta.
Se seu ambiente do Active Directory tiver uma UO designada para novos objetos de computador, você deverá especificar essa UO ao ingressar no domínio.
Se você encontrar erros de acesso negado ao tentar ingressar na UO designada, consulte o administrador do domínio do Active Directory. Talvez o administrador precise pré-preparar a conta do computador do gateway para que ele possa ingressar no domínio. Para acessar mais informações, consulte Como soluciono problemas ao associar meu Gateway de Arquivos do Storage Gateway a um domínio para autenticação do Microsoft Active Directory?
. -
Verifique se o nome do host do seu gateway pode ser resolvido no DNS executando o comando a seguir no prompt de comando, no console local do gateway. Substitua a variável destacada pelo nome de host real do gateway.
dig -dExampleHostName-r ASe você configurou um nome de host personalizado para seu gateway, deverá adicionar manualmente um DNS A-record que aponte para seu endereço IP.
-
Verifique se a latência da rede entre o gateway e o controlador de domínio está razoavelmente baixa. A consulta para ingressar em um domínio poderá expirar se o gateway não receber uma resposta do controlador de domínio em 20 segundos.
Se você unir o gateway ao domínio usando o comando JoinDomain CLI, poderá adicionar o
--timeout-in-secondssinalizador para aumentar o tempo limite para no máximo 3.600 segundos. -
Confirme se o usuário do Active Directory que você está usando para associar o gateway ao domínio tem os privilégios necessários para isso.
Solução de problemas: uso de CloudWatch métricas
Você pode encontrar informações a seguir sobre ações para resolver problemas usando CloudWatch métricas da Amazon com o Storage Gateway.
Tópicos
O gateway reage lentamente quando você navega por diretórios
Se o File Gateway reage lentamente quando você executa o ls comando ou navega nos diretórios, verifique as métricas IndexFetch e. IndexEviction CloudWatch
-
Se a métrica
IndexFetchfor maior que 0 quando você executar um comandolsou navegar por diretórios, o Gateway de Arquivos foi iniciado sem informações sobre o conteúdo do diretório afetado e precisou acessar o FSx para Windows File Server. Os esforços subsequentes para listar o conteúdo desse diretório deverão ocorrer com mais rapidez. -
Se a métrica
IndexEvictionfor maior que 0, significa que o Gateway de Arquivos atingiu o limite do que pode gerenciar em seu cache no momento. Nesse caso, o Gateway de Arquivos precisa liberar espaço de armazenamento do diretório acessado há mais tempo para listar um novo diretório. Se isso ocorrer com frequência e houver um impacto no desempenho, entre em contato Suporte.Discuta Suporte o conteúdo do sistema de arquivos relacionado ao Amazon FSx e as recomendações para melhorar o desempenho com base no seu caso de uso.
O gateway não está respondendo
Se o Gateway de Arquivos não está respondendo, faça o seguinte:
-
Se essa foi uma reinicialização atual ou uma atualização de software, verifique a métrica
IOWaitPercent. Essa métrica mostra a porcentagem de tempo em que a CPU fica ociosa quando há uma I/O solicitação de disco pendente. Em alguns casos, isso pode ser alto (10 ou mais) e pode ter aumentado depois que o servidor foi reinicializado ou atualizado. Nesses casos, o Gateway de Arquivos pode estar sendo limitado por um disco raiz lento à medida que ele recria o cache de índice para RAM. É possível resolver esse problema usando um disco físico mais rápido para o disco raiz. -
Caso a métrica
MemUsedBytesseja igual ou quase igual à métricaMemTotalBytes, o Gateway de Arquivos está ficando sem RAM disponível. Verifique se o Gateway de Arquivos tem pelo menos a RAM mínima necessária. Se já tiver, pense em adicionar mais RAM ao Gateway de Arquivos com base na workload e no caso de uso.Se o compartilhamento de arquivos for SMB, o problema também pode ser devido ao número de clientes SMB conectados ao compartilhamento de arquivos. Para ver o número de clientes conectados em determinado momento, verifique a métrica
SMBV(1/2/3)Sessions. Se houver muitos clientes conectados, talvez seja necessário adicionar mais RAM ao Gateway de Arquivos.
Não é possível ver arquivos no sistema de arquivos do Amazon FSx
Se você perceber que os arquivos no gateway não aparecem no sistema de arquivos do Amazon FSx, confira a métrica FilesFailingUpload. Se a métrica informar que alguns arquivos estão falhando no upload, confira suas notificações de integridade. Quando não é feito upload dos arquivos, o gateway gera uma notificação de integridade que contém mais detalhes sobre o problema.
Não é possível ver snapshots mais antigos no sistema de arquivos do Amazon FSx
Algumas operações de arquivo no FSx File Gateway, como renomeações de pastas de nível superior ou alterações de permissão, podem resultar em várias operações de arquivo que levam a uma alta I/O carga no sistema de arquivos FSx for Windows File Server. Se seu sistema de arquivos não tiver recursos de desempenho suficientes para sua carga de trabalho, o sistema de arquivos poderá excluir cópias de sombra porque prioriza a disponibilidade para retenção contínua de cópias de sombra em I/O vez de histórica.
No console do Amazon FSx, confira a página Monitoramento e performance para ver se seu sistema de arquivos está subprovisionado. Se estiver, você poderá mudar para o armazenamento de SSD, aumentar a capacidade de throughput ou aumentar o IOPS da SSD para lidar com sua workload.
O gateway demora a transferir dados para o Amazon FSx.
Se o Gateway de Arquivos estiver demorando a transferir dados para o Amazon FSx para Windows File Server, faça o seguinte:
-
Caso a métrica
CachePercentDirtyseja 80 ou mais, significa que o Gateway de Arquivos está gravando dados mais depressa no disco do que consegue fazer upload deles para o Amazon FSx para Windows File Server. Pense em aumentar a largura de banda para upload do seu Gateway de Arquivos, adicionar um ou mais discos de cache, reduzir a velocidade de gravação do cliente ou aumentar a capacidade de throughput do Amazon FSx para Windows File Server associado. -
Se a métrica
CachePercentDirtyestiver baixa, confira a métricaIoWaitPercent. CasoIoWaitPercentseja maior que 10, pode ser que o Gateway de Arquivos esteja sendo limitado pela velocidade do disco de cache local. Recomendamos discos de unidade de estado sólido (SSD) local para o cache, de preferência NVM Express (NVMe). Se esses discos não estiverem disponíveis, tente usar vários discos de cache de discos físicos separados para melhorar o desempenho.
O trabalho de backup do gateway falha ou há erros quando você grava no gateway
Se o trabalho de backup do Gateway de Arquivos falhar ou se houver erros quando você gravar nele, faça o seguinte:
-
Se a métrica
CachePercentDirtyfor 90% ou mais, o Gateway de Arquivos não poderá aceitar novas gravações em disco porque não há espaço disponível suficiente no disco de cache. Para ver a rapidez com que seu Gateway de Arquivos está fazendo upload para o FSx para Windows File Server, visualize a métricaCloudBytesUploaded. Compare essa métrica com a métricaWriteBytes, que mostra a rapidez com que o cliente está gravando arquivos no Gateway de Arquivos. Se o cliente SMB estiver gravando no Gateway de Arquivos mais rápido do que consegue fazer upload para o FSx para Windows File Server, adicione mais discos de cache para cobrir, no mínimo, o tamanho do trabalho de backup. Ou aumente a largura de banda de upload. -
Se a cópia de um arquivo grande, como um trabalho de backup falhar, mas a métrica
CachePercentDirtyfor inferior a 80%, o Gateway de Arquivos poderá estar atingindo um tempo limite de sessão no lado do cliente. Para SMB, você pode aumentar esse tempo limite usando o PowerShell comando.Set-SmbClientConfiguration -SessionTimeout 300A execução desse comando define o tempo limite para 300 segundos.