

기계 번역으로 제공되는 번역입니다. 제공된 번역과 원본 영어의 내용이 상충하는 경우에는 영어 버전이 우선합니다.

# Windows Server 권한 문제 해결
<a name="troubleshoot-entitlements"></a>

이 주제에서는 Windows Server 권한 부여와 관련하여 발생할 수 있는 일반적인 문제와 이를 해결하는 방법을 설명합니다.

## 권한 부여 상태는 입니다. `AT_RISK`
<a name="troubleshoot-entitlement-at-risk"></a>

연결된 vCenter 커넥터가 연결성 검사에 실패하면(즉, vCenter 커넥터 연결성 검사 상태가 실패로 표시됨) 권한이 `AT_RISK` 상태가 됩니다. 이 장애는 영향을 받는 vCenter Server 어플라이언스의 모든 Windows Server 가상 머신(VMs)에 대한 권한에 영향을 미칩니다.

vCenter 연결성 검사가 연결 복원에 실패하기 시작한 시점으로부터 8시간이 경과해야 합니다.
+ 8시간 유예 기간 내에 연결을 복원하면 Amazon EVS는 모든 지연 이벤트를 복구하고 추가 작업 없이 Windows Server VM 권한을 유지합니다.
+ 연결이 8시간 유예 기간 내에 복원되지 않으면 Amazon EVS는 권한을 제거하고 상태를 로 변경`ENTITLEMENT_REMOVED`하며 Personal Health Dashboard 알림을 보냅니다. 연결이 끊어지면 Windows Server 라이선스 사용량 추적이 중지됩니다.

이 문제를 해결하려면 다음과 같이 실행합니다.
+ 커넥터 상태가 활성이고 연결성 검사 상태가 실패인지 확인합니다.
+  AWS Secrets Manager에 저장된 어플라이언스 자격 증명이 최신 상태이고 올바른지 확인합니다. 자격 증명이 변경된 경우 자격 증명을 업데이트합니다. 자세한 내용은 [ vCenter 커넥터 자격 증명 교체를 참조하세요](rotate-vcenter-credentials.md).
+ 서비스 액세스 서브넷에서 DNS 서버에 연결할 수 있고, 어플라이언스 FQDN에 대한 DNS 레코드가 유효하며, 중복 호스트 이름 또는 IP 주소가 없는지 확인합니다.
+ 방화벽 규칙이 관리 VM VLAN 서브넷에 대한 HTTPS/SSH 액세스와 DNS 서버에 대한 TCP/UDP 액세스를 허용하는지 확인합니다.
+ 어플라이언스가 실행 중이고 액세스 가능한지 확인합니다.

이 지침을 따른 후에도 여전히 문제를 해결할 수 없는 경우 AWS Support에 문의하여 추가 지원을 받는 것이 좋습니다.

## 권한 부여 상태는 입니다. `ENTITLEMENT_REMOVED`
<a name="troubleshoot-entitlement-removed"></a>

`ENTITLEMENT_REMOVED` 상태가 인 권한은 Amazon EVS가 VM에 대한 권한을 제거했음을 나타냅니다. 권한이 제거되면 Amazon EVS는 영향을 받는 VM에 대한 Windows Server 라이선스 사용량 추적을 중지합니다.

**참고**  
90일 동안 `ENTITLEMENT_REMOVED` 상태로 유지되는 권한은 자동으로 삭제됩니다.

`ENTITLEMENT_REMOVED` 상태는 다음 시나리오에서 비롯될 수 있습니다.
+ vCenter 커넥터 연결성 실패는 8시간 유예 기간 이후에도 해결되지 않은 상태로 유지되어 권한이에서 `AT_RISK`로 이동되었습니다`ENTITLEMENT_REMOVED`. 자세한 내용은 [권한 부여 상태가 임을 참조하세요`AT_RISK`](#troubleshoot-entitlement-at-risk).
+ VM이 연결 해제되거나 분리된 상태이거나 액세스할 수 없는 경우 일반적으로 기본 호스트 또는 네트워크 문제를 나타냅니다.
+ VM이 더 이상 vCenter 인벤토리에 없습니다.
+ VM 게스트 OS가 지원되지 않는 버전으로 변경되었습니다. Amazon EVS는 Windows Server 2016 이상을 지원합니다.

권한을 복원하려면 먼저 권한의 오류 세부 정보를 확인하여 제거의 특정 원인을 식별합니다. 그런 다음 원인을 기반으로 다음을 수행합니다.

1. 유예 기간을 초과한 vCenter 연결성 실패로 인해 권한이 제거된 경우 vCenter Server 연결을 복원합니다.

1. VM이 연결 해제, 분리 또는 액세스할 수 없어 권한이 제거된 경우 vCenter에서 VM의 연결 상태를 확인하고 기본 문제를 해결하여 VM이 규정 준수 상태로 돌아갑니다. 호스트가 vCenter에 대한 연결을 끊고 vSphere HA가 다른 호스트에서 VM을 복구하지 못하면 VM 연결이 끊어질 수 있습니다. 스토리지 연결 문제 또는 마이그레이션 중단으로 인해 VM이 분리될 수 있습니다.

1. VM이 vCenter 인벤토리에 더 이상 존재하지 않아 권한이 제거된 경우 vCenter에서 VM을 복원합니다.

1. VM에 지원되지 않는 게스트 OS가 있어 권한이 제거된 경우 게스트 OS를 지원되는 버전으로 업데이트합니다. Amazon EVS는 Windows Server 2016 이상을 지원합니다.

VCF 환경에서 기본 문제를 해결한 후 Amazon EVS는 영향을 받는 권한을 검증하고 그 직후 자동으로 복원합니다. EVS가 VMs이 규정 준수를 복원했는지 성공적으로 검증한 시점부터 권한이 재개됩니다.

이 지침을 따른 후에도 여전히 문제를 해결할 수 없는 경우 AWS Support에 문의하여 추가 지원을 받는 것이 좋습니다.