Le traduzioni sono generate tramite traduzione automatica. In caso di conflitto tra il contenuto di una traduzione e la versione originale in Inglese, quest'ultima prevarrà.
Configurazione di un test
Quando si crea un test da un modello, si configurano le seguenti impostazioni. Le impostazioni vengono salvate e riutilizzate per le esecuzioni future: puoi modificarle in qualsiasi momento.
- Durata del test
-
La durata dell'esecuzione delle azioni di test. Per i test di ripristino (Availability Zone: recovery e Multi-Region: recovery), la durata predefinita è l'RTO più 30 minuti, in modo da concedere al servizio il tempo necessario per il ripristino e a conferma del corretto funzionamento. Per i test sostenuti, l'impostazione predefinita è 30 minuti per la convalida delle dipendenze o 3 ore per: isolamento. Multi-Region Queste impostazioni predefinite si applicano nella console; quando si utilizza l'API, si fornisce la durata in modo esplicito.
- Ambito dell'errore
-
Definisce dove vengono iniettati i guasti: la zona di disponibilità o le regioni da compromettere. Ogni test ha i propri parametri. Per informazioni dettagliate, vedi Test disponibili.
- Azioni di test
-
Read-only. Definito dal modello di test. Mostra le azioni di errore e i relativi tipi di risorse di destinazione. Se nessuna risorsa corrisponde al tipo di obiettivo di un'azione, tale azione viene ignorata.
- Dipendenze da bloccare
-
Dipendenze da bloccare durante il test. Seleziona una delle dipendenze scoperte (se il rilevamento delle dipendenze è abilitato) o inserisci le dipendenze manualmente in base al nome di dominio DNS. Obbligatorio per alcuni test, opzionale per altri. Per le impostazioni predefinite e i requisiti, vedere. Test disponibili
- Allarmi di prova
-
Allarmi di successo (obbligatori): gli CloudWatch allarmi che determinano i criteri di successo hanno esito positivo o negativo. È necessario specificare almeno un valore. Se ne selezioni più, è necessario che tutti abbiano esito positivo affinché il test venga superato. Scegli allarmi che misurino lo stato generale del tuo servizio.
Come viene superato il test:
-
Zona di disponibilità: ripristino: tutti gli allarmi di esito positivo devono tornare allo
OKstato compreso nell' Multi-AZ RTO e rimanere lì fino al termine delle azioni di test. -
Multi-Region: ripristino: tutti gli allarmi di esito positivo devono tornare allo
OKstato compreso nell' Multi-Region RTO e rimanere lì fino al termine delle azioni di test. -
Convalida delle dipendenze: tutti gli allarmi di esito positivo rimangono invariati fino al termine
OKdelle azioni di test. -
Multi-Region: isolamento: tutti gli allarmi di successo rimangono in
OKstato fino al termine delle azioni di test.
Allarmi aggiuntivi (opzionali): solo per l'osservabilità. Vengono visualizzati nei risultati e nel rapporto, ma non influiscono sull'esito positivo o negativo.
-
- Piano di cambio di regione (Multi-Region: solo ripristino, opzionale)
-
L'aggiunta di un piano di switch regionale AWS dell'Application Recovery Controller (ARC) consente alla nuova generazione di Resilience Hub di includere la tempistica del failover nei risultati dei test e nel rapporto. Facoltativo; lascia vuoto se utilizzi il failover manuale o un'automazione personalizzata.
- Impostazioni aggiuntive (opzionali)
-
- Condizioni di arresto
-
CloudWatch allarmi che interrompono automaticamente il test in caso di superamento della soglia. Utilizzate le condizioni di arresto come barriere per proteggere i carichi di lavoro durante i test. Ad esempio, crea un CloudWatch allarme su una metrica aziendale critica (come la latenza o il tasso di errore) che interrompa il test se supera una soglia inaccettabile. Gli allarmi relativi alla condizione di arresto devono essere presenti nell'account in cui viene eseguito il test e nella regione in cui vengono iniettati i guasti. Per ulteriori informazioni, consulta Condizioni di arresto per. AWS FIS
- Report
-
Un report viene generato automaticamente dopo ogni esecuzione di test quando una destinazione del report (bucket Amazon S3) è configurata sul servizio. I report includono la configurazione del test, lo stato degli allarmi, la tempistica e i risultati superati o non riusciti. I report di test sono inclusi senza costi aggiuntivi quando si utilizza la nuova generazione di test di resilienza Resilience Hub. Per configurare la destinazione di un report, consulta le impostazioni di reporting del tuo servizio.
- Log
-
Invia registri di test dettagliati ad Amazon S3, CloudWatch Logs o entrambi. I log registrano gli eventi con data e ora, tra cui l'inizio e la fine dell'azione, la risoluzione del target e gli errori. Utilizza i log per eseguire il debug dei test non riusciti o per comprendere la sequenza di iniezione degli errori. La registrazione richiede autorizzazioni aggiuntive sul ruolo di esecuzione del test. Per ulteriori informazioni, vedere Registrazione degli esperimenti per. AWS FIS
- Autorizzazioni di test
-
È richiesto un ruolo di esecuzione IAM. Le autorizzazioni variano in base al tipo di test, alle azioni di errore e alle opzioni selezionate. Per i test con più account, utilizza lo stesso ruolo in ogni account. Per ulteriori informazioni, consulta Ruoli di esecuzione IAM per i test di resilienza.