View a markdown version of this page

Seeing cannot change locale (en_US.utf-8) perché ha un nome non valido in slurm_resume.log - AWS ParallelCluster

Le traduzioni sono generate tramite traduzione automatica. In caso di conflitto tra il contenuto di una traduzione e la versione originale in Inglese, quest'ultima prevarrà.

Seeing cannot change locale (en_US.utf-8) perché ha un nome non valido in slurm_resume.log

Ciò può verificarsi se si verifica un processo di yum installazione non riuscito che ha lasciato le impostazioni locali in uno stato incoerente. Ad esempio, ciò può verificarsi quando un utente termina il processo di installazione.

Per verificare la causa, intraprendi le seguenti azioni:
  • Esegui su - pcluster-admin.

    La shell mostra un errore, ad esempio,cannot change locale...no such file or directory.

  • Esegui localedef --list.

    Restituisce un elenco vuoto o non contiene le impostazioni locali predefinite.

  • Controlla l'ultimo yum comando con yum history eyum history info #ID. L'ultimo ID haReturn-Code: Success?

    Se l'ultimo ID non è presenteReturn-Code: Success, gli script di post-installazione potrebbero non essere stati eseguiti correttamente.

Per risolvere il problema, prova a ricostruire la versione locale con. yum reinstall glibc-all-langpacks Dopo la ricostruzione, su - pcluster-admin non mostra un errore o un avviso se il problema è stato risolto.