Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.
Configuration d'un test
Lorsque vous créez un test à partir d'un modèle, vous configurez les paramètres suivants. Les paramètres sont enregistrés et réutilisés pour les prochaines exécutions. Vous pouvez les modifier à tout moment.
- Durée du test
-
Durée d'exécution des actions de test. Pour les tests de restauration (zone de disponibilité : restauration et Multi-Region : restauration), la durée par défaut est votre RTO plus 30 minutes, ce qui donne à votre service le temps de restauration et confirme qu'il est maintenu. Pour les tests soutenus, la valeur par défaut est de 30 minutes pour la validation des dépendances ou de 3 heures pour Multi-Region : l'isolement. Ces valeurs par défaut s'appliquent dans la console ; lorsque vous utilisez l'API, vous indiquez la durée de manière explicite.
- Étendue du défaut
-
Définit l'endroit où les défauts sont injectés : la zone de disponibilité ou les régions à modifier. Chaque test possède ses propres paramètres. Pour en savoir plus, consultez Tests disponibles.
- Actions de test
-
Read-only. Défini par le modèle de test. Affiche les actions d'erreur et leurs types de ressources cibles. Si aucune ressource ne correspond au type de cible d'une action, celle-ci est ignorée.
- Dépendances à bloquer
-
Dépendances à bloquer pendant le test. Choisissez parmi les dépendances découvertes (si la découverte des dépendances est activée) ou entrez les dépendances manuellement par nom de domaine DNS. Obligatoire pour certains tests, facultatif pour d'autres. Pour connaître les valeurs par défaut et les exigences, consultezTests disponibles.
- Alarmes de test
-
Alarmes de réussite (obligatoire) : CloudWatch alarmes qui déterminent la réussite ou l'échec des critères de réussite. Au moins une unité est obligatoire. Si vous en sélectionnez plusieurs, vous devez tous réussir le test. Choisissez des alarmes qui mesurent l'état de santé général de votre service.
Comment réussir le test :
-
Zone de disponibilité : restauration : toutes les alarmes de réussite doivent revenir à
OKl'état de votre Multi-AZ RTO et y rester jusqu'à la fin des actions de test. -
Multi-Region: restauration : toutes les alarmes de réussite doivent revenir à
OKl'état de votre Multi-Region RTO et y rester jusqu'à la fin des actions de test. -
Validation des dépendances : toutes les alarmes de réussite restent
OKactives jusqu'à la fin des actions de test. -
Multi-Region: isolation : toutes les alarmes de réussite restent actives
OKjusqu'à la fin des actions de test.
Alarmes supplémentaires (facultatives) — À des fins d'observabilité uniquement. Elles sont affichées dans les résultats et le rapport, mais n'ont aucune incidence sur le résultat de réussite ou d'échec.
-
- Plan de changement de région (Multi-Regionrestauration uniquement, en option)
-
L'ajout d'un plan de commutateur de région du contrôleur de reprise d' AWS application (ARC) permet à la prochaine génération de Resilience Hub d'inclure le calendrier du basculement dans les résultats de vos tests et dans votre rapport. Facultatif ; laissez ce champ vide si vous utilisez le basculement manuel ou une automatisation personnalisée.
- Paramètres supplémentaires (facultatif)
-
- Conditions d'arrêt
-
CloudWatch des alarmes qui interrompent automatiquement le test en cas de dépassement de leur seuil. Utilisez les conditions d'arrêt comme garde-fous pour protéger vos charges de travail pendant les tests. Par exemple, créez une CloudWatch alarme sur une métrique commerciale critique (telle que la latence ou le taux d'erreur) qui arrête le test s'il dépasse un seuil inacceptable. Les alarmes de condition d'arrêt doivent se trouver dans le compte où le test est exécuté et dans la région où les défauts sont injectés. Pour plus d'informations, voir Conditions d'arrêt pour AWS FIS.
- Rapports
-
Un rapport est automatiquement généré après chaque exécution de test lorsqu'une destination de rapport (compartiment Amazon S3) est configurée sur votre service. Les rapports incluent la configuration des tests, l'état des alarmes, la chronologie et les résultats de réussite ou d'échec. Les rapports de test sont inclus sans frais supplémentaires lorsque vous utilisez la nouvelle génération de tests de résilience Resilience Hub. Pour configurer la destination d'un rapport, consultez les paramètres de création de rapports de votre service.
- Journaux
-
Envoyez des journaux de test détaillés à Amazon S3, à CloudWatch Logs, ou aux deux. Les journaux capturent les événements horodatés, notamment le début et la fin des actions, la résolution cible et les erreurs. Utilisez les journaux pour déboguer les tests qui ont échoué ou pour comprendre la séquence d'injection des défauts. La journalisation nécessite des autorisations supplémentaires sur votre rôle d'exécution des tests. Pour plus d'informations, voir Enregistrement des expériences pour AWS FIS.
- Autorisations de test
-
Un rôle d'exécution IAM est requis. Les autorisations varient en fonction du type de test, des actions d'erreur et des options sélectionnées. Pour les tests multi-comptes, utilisez le rôle du même nom dans chaque compte. Pour de plus amples informations, veuillez consulter Rôles d'exécution IAM pour les tests de résilience.