View a markdown version of this page

Seeing ne peut pas changer les paramètres régionaux (en_US.utf-8) car son nom n'est pas valide dans slurm_resume.log - AWS ParallelCluster

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Seeing ne peut pas changer les paramètres régionaux (en_US.utf-8) car son nom n'est pas valide dans slurm_resume.log

Cela peut se produire si le processus d'yuminstallation échoue et que les paramètres régionaux sont restés dans un état incohérent. Par exemple, cela peut se produire lorsqu'un utilisateur met fin au processus d'installation.

Pour en vérifier la cause, effectuez les actions suivantes :
  • Exécutez su - pcluster-admin.

    Le shell affiche une erreur, telle que,cannot change locale...no such file or directory.

  • Exécutez localedef --list.

    Renvoie une liste vide ou ne contient pas les paramètres régionaux par défaut.

  • Vérifiez la dernière yum commande avec yum history etyum history info #ID. Est-ce que je possède la dernière carte d'identité Return-Code: Success ?

    Si le dernier identifiant n'est pas indiquéReturn-Code: Success, les scripts de post-installation ne se sont peut-être pas exécutés correctement.

Pour résoudre le problème, essayez de reconstruire les paramètres régionaux avecyum reinstall glibc-all-langpacks. Après la reconstruction, su - pcluster-admin aucune erreur ou avertissement n'apparaît si le problème est résolu.