Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.
Résolution des problèmes : problèmes liés à la passerelle de fichiers
Vous pouvez configurer votre File Gateway pour écrire des entrées de journal dans un groupe de CloudWatch journaux Amazon. Si vous le faites, vous recevez des notifications concernant l'état de santé de la passerelle et les éventuelles erreurs rencontrées par la passerelle. Vous trouverez des informations sur ces notifications d'erreur et de santé dans CloudWatch les journaux.
Dans les sections suivantes, vous trouverez des informations qui peuvent vous aider à comprendre la cause de chaque notification d'erreur et d'intégrité et à résoudre les problèmes.
Rubriques
Erreur : 1344 (0x00000540)
Lors de la migration de fichiers vers Amazon S3, vous pouvez rencontrer un ERROR 1344
(0x00000540) problème si vous essayez de copier des fichiers contenant plus de 10 entrées de contrôle d'accès (ACE) dans Amazon S3. Les entrées de contrôle d'accès sont répertoriées dans la liste de contrôle d'accès (ACL).
Amazon S3 File Gateway ne peut conserver que 10 entrées ACE par fichier ou dossier donné.
Pour résoudre une erreur 1344 : copie de la sécurité NTFS dans le répertoire de destination.
Réduisez le nombre d'entrées dans les autorisations Windows pour les fichiers ou les dossiers contenant plus de 10 entrées. Une approche courante consiste à créer un groupe contenant la liste complète des entrées, puis à remplacer la liste des entrées par ce groupe unique. Une fois que le nombre d'entrées est inférieur à 10, vous pouvez réessayer de copier les fichiers ou les dossiers sur la passerelle.
Erreur : GatewayClockOutOfSync
Vous pouvez obtenir un GatewayClockOutOfSync message d'erreur lorsque la passerelle détecte une différence de 5 minutes ou plus entre l'heure du système local et l'heure indiquée par les serveurs AWS Storage Gateway. Les problèmes de synchronisation de l'horloge peuvent avoir un impact négatif sur la connectivité entre la passerelle et AWS. Si l'horloge de la passerelle n'est pas synchronisée, des I/O erreurs peuvent se produire pour les connexions NFS et SMB, et les utilisateurs SMB peuvent rencontrer des erreurs d'authentification.
Pour résoudre une GatewayClockOutOfSync erreur
-
Vérifiez la configuration réseau entre la passerelle et le serveur NTP. Pour plus d'informations sur la synchronisation de l'heure de la machine virtuelle de la passerelle et la mise à jour de la configuration du serveur NTP, consultez Configuration d'un serveur NTP (Network Time Protocol) pour votre passerelle
Erreur : InaccessibleStorageClass
Un InaccessibleStorageClass message d'erreur peut s'afficher lorsqu'un objet sort de la classe de stockage Amazon S3 Standard.
Votre passerelle de fichiers rencontre généralement cette erreur lorsqu'elle essaie de télécharger un objet ou de lire un objet depuis le compartiment Amazon S3. Généralement, cette erreur signifie que l'objet a été déplacé vers Amazon Glacier et qu'il appartient à la classe de stockage S3 Glacier Flexible Retrieval ou à la classe de stockage S3 Glacier Deep Archive.
Votre passerelle de fichiers S3 peut générer un rapport de cache répertoriant tous les fichiers du cache de la passerelle qui ne peuvent actuellement pas être chargés sur Amazon S3 en raison de cette erreur. Les informations contenues dans ce rapport peuvent vous aider Support à résoudre les problèmes liés à votre passerelle, à Amazon S3 ou à la configuration IAM. Pour plus d'informations, voir Création d'un rapport de cache.
Pour résoudre une InaccessibleStorageClass erreur
-
Restaurez l'objet depuis la classe de stockage S3 Glacier Flexible Retrieval ou S3 Glacier Deep Archive vers sa classe de stockage d'origine dans S3.
Si vous restaurez l'objet dans le compartiment S3 pour corriger une erreur de chargement, le fichier est finalement chargé. Si vous restaurez l'objet pour corriger une erreur de lecture, le client SMB ou NFS de File Gateway peut alors lire le fichier.
Erreur : InvalidObjectState
Vous pouvez obtenir une InvalidObjectState erreur lorsqu'un rédacteur autre que la passerelle de fichiers spécifiée modifie le fichier spécifié dans le compartiment Amazon S3 spécifié. Par conséquent, l'état du fichier pour File Gateway ne correspond pas à son état dans Amazon S3. Les chargements ultérieurs du fichier vers Amazon S3 ou les extractions du fichier depuis Amazon S3 échouent.
Votre passerelle de fichiers S3 peut générer un rapport de cache répertoriant tous les fichiers du cache de la passerelle qui ne peuvent actuellement pas être chargés sur Amazon S3 en raison de cette erreur. Les informations contenues dans ce rapport peuvent vous aider Support à résoudre les problèmes liés à votre passerelle, à Amazon S3 ou à la configuration IAM. Pour plus d'informations, voir Création d'un rapport de cache.
Pour résoudre une InvalidObjectState erreur
Si l'opération qui modifie le fichier est S3Upload ouS3GetObject, procédez comme suit :
-
Enregistrez la dernière copie du fichier dans le système de fichiers local de votre client SMB ou NFS (vous aurez besoin de cette copie de fichier à l'étape 4). Si la version du fichier dans Amazon S3 est la plus récente, téléchargez-la. Vous pouvez le faire à l'aide de la Console de gestion AWS touche ou AWS CLI.
-
Supprimez le fichier dans Amazon S3 à l'aide du Console de gestion AWS bouton ou AWS CLI.
-
Supprimez le fichier de la passerelle de fichiers à l'aide de votre client SMB ou NFS.
-
Copiez la dernière version du fichier que vous avez enregistré à l'étape 1 sur Amazon S3 à l'aide de votre client SMB ou NFS. Pour ce faire, utilisez votre passerelle de fichiers.
Erreur : ObjectMissing
Vous pouvez obtenir une ObjectMissing erreur lorsqu'un rédacteur autre que la passerelle de fichiers spécifiée supprime le fichier spécifié du compartiment S3. Tous les chargements ultérieurs vers Amazon S3 ou les extractions depuis Amazon S3 pour l'objet échouent.
Votre passerelle de fichiers S3 peut générer un rapport de cache répertoriant tous les fichiers du cache de la passerelle qui ne peuvent actuellement pas être chargés sur Amazon S3 en raison de cette erreur. Les informations contenues dans ce rapport peuvent vous aider Support à résoudre les problèmes liés à votre passerelle, à Amazon S3 ou à la configuration IAM. Pour plus d'informations, voir Création d'un rapport de cache.
Pour résoudre une ObjectMissing erreur
Si l'opération qui modifie le fichier est S3Upload ouS3GetObject, procédez comme suit :
-
Enregistrez la dernière copie du fichier dans le système de fichiers local de votre client SMB ou NFS (vous aurez besoin de cette copie de fichier à l'étape 3).
-
Supprimez le fichier de la passerelle de fichiers à l'aide de votre client SMB ou NFS.
-
Copiez la dernière version du fichier que vous avez enregistré à l'étape 1 à l'aide de votre client SMB ou NFS. Pour ce faire, utilisez votre passerelle de fichiers.
Erreur : RoleTrustRelationshipInvalid
Cette erreur s'affiche lorsque le rôle IAM d'un partage de fichiers présente une relation de confiance IAM mal configurée (c'est-à-dire que le rôle IAM ne fait pas confiance au principal de Storage Gateway désigné). storagegateway.amazonaws.com Par conséquent, la passerelle de fichiers ne serait pas en mesure d'obtenir les informations d'identification nécessaires pour exécuter des opérations sur le compartiment S3 qui sauvegarde le partage de fichiers.
Pour résoudre une RoleTrustRelationshipInvalid erreur
-
Utilisez la console IAM ou l'API IAM pour inclure en
storagegateway.amazonaws.com.rproxy.govskope.catant que principal le rôle IAMRole de votre partage de fichiers approuvé. Pour plus d'informations sur le rôle IAM, consultez Tutoriel : déléguer l'accès à plusieurs AWS comptes à l'aide de rôles IAM.
Erreur : S3AccessDenied
Vous pouvez obtenir une S3AccessDenied erreur concernant le rôle d'accès au compartiment Amazon S3 Gestion des identités et des accès AWS (IAM) d'un partage de fichiers. Dans ce cas, le rôle IAM d'accès au compartiment S3 spécifié par roleArn dans l'erreur n'autorise pas l'opération concernée. L'opération n'est pas autorisée en raison des autorisations pour les objets du répertoire spécifiées par le préfixe Amazon S3.
Votre passerelle de fichiers S3 peut générer un rapport de cache répertoriant tous les fichiers du cache de la passerelle qui ne peuvent actuellement pas être chargés sur Amazon S3 en raison de cette erreur. Les informations contenues dans ce rapport peuvent vous aider Support à résoudre les problèmes liés à votre passerelle, à Amazon S3 ou à la configuration IAM. Pour plus d'informations, voir Création d'un rapport de cache.
Pour résoudre une S3AccessDenied erreur
-
Modifiez la politique d'accès Amazon S3 associée
roleArnau journal d'état de File Gateway pour autoriser les opérations Amazon S3. Assurez-vous que la stratégie d'accès autorise l'opération à l'origine de l'erreur. En outre, permettez l'autorisation pour le répertoire spécifié dans le journal deprefix. Pour plus d'informations sur les autorisations Amazon S3, consultez la section Définition des autorisations dans une politique dans le Guide de l'utilisateur d'Amazon Simple Storage Service.Ces opérations peuvent entraîner cette erreur
S3AccessDenied:-
S3HeadObject -
S3GetObject -
S3ListObjects -
S3DeleteObject -
S3PutObject
-
Erreur : DroppedNotifications
Une DroppedNotifications erreur peut s'afficher à la place des autres types d'entrées de CloudWatch journal attendus lorsque l'espace de stockage disponible sur le disque racine de votre passerelle est inférieur à 1 Go ou si plus de 100 notifications d'état sont générées dans un intervalle d'une minute. Dans ces circonstances, la passerelle cesse de générer des notifications de CloudWatch journal détaillées par mesure de précaution.
Pour résoudre une DroppedNotifications erreur
-
Consultez la
Root Disk Usagemétrique de l'onglet Surveillance de votre passerelle dans la console Storage Gateway pour déterminer si l'espace disponible sur le disque racine est insuffisant. -
Augmentez la taille du disque de stockage racine de la passerelle si l'espace disponible est inférieur à 1 Go. Reportez-vous à la documentation de l'hyperviseur de votre machine virtuelle pour obtenir des instructions.
Pour augmenter la taille du disque racine pour les passerelles Amazon EC2, consultez la section Demander des modifications à vos volumes EBS dans le guide de l'utilisateur Amazon Elastic Compute Cloud.
Note
Il n'est pas possible d'augmenter la taille du disque racine de l'appliance matérielle AWS Storage Gateway.
-
Redémarrez la passerelle.
Notification : HardReboot
Vous pouvez obtenir une notification HardReboot lorsque la machine virtuelle de la passerelle est redémarrée de façon inattendue. Un tel redémarrage peut être dû à une perte de puissance, à une défaillance matérielle ou à un autre événement. Pour les passerelles VMware, une réinitialisation par vSphere High Availability Application Monitoring peut provoquer cet événement.
Lorsque votre passerelle s’exécute dans un tel environnement, vérifiez la présence de la notification HealthCheckFailure et consultez le journal des événements VMware pour la machine virtuelle.
Notification : Reboot
Vous pouvez obtenir une notification de redémarrage lorsque la machine virtuelle de la passerelle est redémarrée. Vous pouvez redémarrer une machine virtuelle de passerelle à l’aide de la console de gestion des hyperviseurs de la machine virtuelle ou de la console Storage Gateway. Vous pouvez également la redémarrer à l’aide du logiciel de la passerelle pendant le cycle de maintenance de la passerelle.
Si l'heure du redémarrage se situe dans les 10 minutes de l'heure de démarrage de la maintenance configurée de la passerelle, ce redémarrage est probablement une occurrence normale et non un signe de problème. Si le redémarrage s’est produit largement en dehors de la fenêtre de maintenance, vérifiez si la passerelle a été redémarrée manuellement.
Résolution des problèmes : les scans de sécurité indiquent que les ports NFS sont ouverts
Certains ports NFS sont activés par défaut, même sur les passerelles que vous utilisez uniquement avec des partages de fichiers SMB. Si vous utilisez un logiciel de sécurité tiers tel que Qualys pour analyser le réseau sur lequel votre File Gateway est déployée, les résultats de l'analyse peuvent indiquer que ces ports NFS ouverts constituent une faille de sécurité potentielle. Si vous utilisez votre passerelle uniquement avec des partages de fichiers SMB et que vous souhaitez désactiver les ports NFS non utilisés pour des raisons de sécurité, procédez comme suit :
Pour désactiver les ports NFS sur une passerelle de fichiers, procédez comme suit :
-
Accédez à l'invite de commande de la console locale de la passerelle en suivant la procédure décrite dansExécution des commandes Storage Gateway sur la console locale.
-
Entrez les commandes suivantes pour désactiver le trafic NFS :
IPv4
iptables -I INPUT -p udp -m udp --dport 111 -j DROP iptables -I INPUT -p udp -m udp --dport 2049 -j DROP iptables -I INPUT -p udp -m udp --dport 20048 -j DROP iptables -I INPUT -p tcp -m tcp --dport 111 -j DROP iptables -I INPUT -p tcp -m tcp --dport 2049 -j DROP iptables -I INPUT -p tcp -m tcp --dport 20048 -j DROPIPv6
ip6tables -I INPUT -p udp -m udp --dport 111 -j DROP ip6tables -I INPUT -p udp -m udp --dport 2049 -j DROP ip6tables -I INPUT -p udp -m udp --dport 20048 -j DROP ip6tables -I INPUT -p tcp -m tcp --dport 111 -j DROP ip6tables -I INPUT -p tcp -m tcp --dport 2049 -j DROP ip6tables -I INPUT -p tcp -m tcp --dport 20048 -j DROP -
Entrez la commande suivante pour confirmer que les ports NFS bloqués apparaissent dans les tables IP :
IPv4
iptables -n -L -v --line-numbersIPv6
ip6tables -n -L -v --line-numbers
Résolution des problèmes : utilisation de CloudWatch métriques
Vous trouverez ci-dessous des informations sur les mesures à prendre pour résoudre les problèmes liés à l'utilisation CloudWatch des métriques Amazon avec Storage Gateway.
Rubriques
Votre passerelle réagit lentement lorsque vous parcourez les annuaires
Si votre passerelle de fichiers réagit lentement lorsque vous exécutez la ls commande ou que vous parcourez des répertoires, vérifiez les IndexEviction CloudWatch indicateurs IndexFetch et :
-
Si la
IndexFetchmétrique est supérieure à 0 lorsque vous exécutez unelscommande ou que vous parcourez des répertoires, votre passerelle de fichiers a démarré sans informations sur le contenu du répertoire concerné et a dû accéder à Amazon S3 . Les opérations ultérieures pour répertorier le contenu de ce répertoire devraient s'exécuter plus rapidement. -
Si la
IndexEvictionmétrique est supérieure à 0, cela signifie que votre passerelle de fichiers a atteint la limite de ce qu'elle peut gérer dans son cache à ce moment-là. Dans ce cas, votre passerelle de fichiers doit libérer de l'espace de stockage dans le répertoire le moins récemment consulté pour répertorier un nouveau répertoire. Si cela se produit fréquemment et que cela a un impact sur les performances, contactez Support.Discutez Support du contenu du compartiment S3 associé et des recommandations pour améliorer les performances en fonction de votre cas d'utilisation.
Votre passerelle ne répond pas
Si votre passerelle de fichiers ne répond pas, procédez comme suit :
-
Dans le cas d'une mise à jour logicielle ou d’un redémarrage récent, vérifiez la métrique
IOWaitPercent. Cette métrique indique le pourcentage de temps pendant lequel le processeur est inactif lorsqu'une I/O demande de disque est en attente. Dans certains cas, ce pourcentage peut être élevé (10 ou plus) et peut avoir augmenté après le redémarrage ou la mise à jour du serveur. Dans ces cas, votre passerelle de fichiers peut être bloquée par un disque racine lent alors qu'elle reconstruit le cache d'index en RAM. Vous pouvez résoudre ce problème en utilisant un disque physique plus rapide pour le disque racine. -
Si la
MemUsedBytesmétrique est égale ou presque identique à laMemTotalBytesmétrique, cela signifie que votre passerelle de fichiers est à court de RAM disponible. Assurez-vous que votre passerelle de fichiers dispose au moins de la RAM minimale requise. Si c'est déjà le cas, pensez à ajouter de la RAM à votre passerelle de fichiers en fonction de votre charge de travail et de votre cas d'utilisation.Si le partage de fichiers est SMB, le problème peut également être dû au nombre de clients SMB connectés au partage de fichiers. Pour connaître le nombre de clients connectés à un moment donné, vérifiez la métrique
SMBV(1/2/3)Sessions. Si de nombreux clients sont connectés, il se peut que vous deviez ajouter de la RAM à votre passerelle de fichiers.
Votre passerelle est lente à transférer des données vers Amazon S3
Si votre passerelle de fichiers est lente à transférer des données vers Amazon S3, procédez comme suit :
-
Si la
CachePercentDirtymétrique est supérieure ou égale à 80, votre File Gateway écrit les données sur le disque plus rapidement qu'elle ne peut les télécharger sur Amazon S3. Envisagez d'augmenter la bande passante pour le téléchargement depuis votre passerelle de fichiers, d'ajouter un ou plusieurs disques de cache ou de ralentir les écritures des clients. -
Si la
CachePercentDirtymétrique est faible,IoWaitPercentvérifiez-la. SiIoWaitPercentcette valeur est supérieure à 10, votre passerelle de fichiers est peut-être bloquée par la vitesse du disque cache local. Nous recommandons des disques SSD (Solid State Drive) locaux pour votre cache, de préférence NVM Express (NVMe). Si de tels disques ne sont pas disponibles, essayez d'utiliser plusieurs disques de cache provenant de disques physiques distincts pour améliorer les performances. -
Si
S3PutObjectRequestTime, ou s'S3GetObjectRequestTimeils sont élevésS3UploadPartRequestTime, il est possible qu'il y ait un goulot d'étranglement sur le réseau. Essayez d'analyser votre réseau pour vérifier que la passerelle dispose de la bande passante attendue.
Votre passerelle effectue plus d'opérations Amazon S3 que prévu
Si votre File Gateway effectue plus d'opérations Amazon S3 que prévu, vérifiez la FilesRenamed métrique. Les opérations de changement de nom sont coûteuses à exécuter dans Amazon S3. Optimisez votre flux de travail pour minimiser le nombre d'opérations de changement de nom.
Aucun fichier ne se trouve dans votre compartiment Amazon S3
Si vous remarquez que les fichiers de la passerelle ne sont pas reflétés dans le compartiment Amazon S3, vérifiez la FilesFailingUpload métrique. Si la métrique indique que le chargement de certains fichiers échoue, vérifiez vos notifications de santé. Lorsque les fichiers ne sont pas chargés, la passerelle génère une notification de santé contenant plus de détails sur le problème.
La tâche de sauvegarde de votre passerelle échoue ou des erreurs se produisent lors de l'écriture sur votre passerelle
Si votre tâche de sauvegarde de File Gateway échoue ou si des erreurs surviennent lors de l'écriture sur votre File Gateway, procédez comme suit :
-
Si la
CachePercentDirtymétrique est supérieure ou égale à 90 %, votre passerelle de fichiers ne peut pas accepter de nouvelles écritures sur le disque car l'espace disponible sur le disque cache est insuffisant. Pour connaître la rapidité avec laquelle votre passerelle de fichiers est chargée vers Amazon S3 , consultez laCloudBytesUploadedmétrique. Comparez cette métrique à laWriteBytesmétrique, qui indique la rapidité avec laquelle le client écrit des fichiers sur votre File Gateway. Si le client SMB écrit sur votre File Gateway plus rapidement qu'il ne peut le télécharger sur Amazon S3 , ajoutez des disques de cache supplémentaires pour couvrir au minimum la taille de la tâche de sauvegarde. Vous pouvez également augmenter la bande passante de chargement. -
Si une copie de fichier volumineuse, telle qu'une tâche de sauvegarde, échoue mais que la
CachePercentDirtymétrique est inférieure à 80 %, il se peut que votre passerelle de fichiers atteigne un délai d'expiration de session côté client. Pour SMB, vous pouvez augmenter ce délai à l'aide de la PowerShell commande.Set-SmbClientConfiguration -SessionTimeout 300L'exécution de cette commande définit le délai d'expiration à 300 secondes.Pour NFS, assurez-vous que le client est monté à l'aide d'un montage physique et non d'un montage logiciel.