View a markdown version of this page

Résolution des problèmes : problèmes liés à la passerelle de fichiers - AWS Storage Gateway

Amazon FSx File Gateway n'est plus disponible pour les nouveaux clients. Les clients existants de FSx File Gateway peuvent continuer à utiliser le service normalement. Pour des fonctionnalités similaires à celles de FSx File Gateway, consultez ce billet de blog.

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Résolution des problèmes : problèmes liés à la passerelle de fichiers

Vous pouvez configurer votre File Gateway pour écrire des entrées de journal dans un groupe de CloudWatch journaux Amazon. Si vous le faites, vous recevez des notifications concernant l'état de santé de la passerelle et les éventuelles erreurs rencontrées par la passerelle. Vous trouverez des informations sur ces notifications d'erreur et de santé dans CloudWatch les journaux.

Dans les sections suivantes, vous trouverez des informations qui peuvent vous aider à comprendre la cause de chaque notification d'erreur et d'intégrité et à résoudre les problèmes.

Erreur : FileMissing

L'FileMissingerreur est similaire à l'ObjectMissingerreur et les étapes pour la résoudre sont identiques. Vous pouvez obtenir un FileMissing message d'erreur lorsqu'un rédacteur autre que la passerelle de fichiers spécifiée supprime le fichier spécifié d'Amazon FSx. Les chargements ultérieurs vers Amazon FSx ou les extractions depuis Amazon FSx pour l'objet échouent.

Pour résoudre une FileMissing erreur
  1. Enregistrez la dernière copie du fichier dans le système de fichiers local de votre client SMB (vous aurez besoin de cette copie de fichier à l'étape 3).

  2. Supprimez le fichier de la passerelle de fichiers à l'aide de votre client SMB.

  3. Copiez la dernière version du fichier que vous avez enregistré à l'étape 1 Amazon FSx à l'aide de votre client SMB. Pour ce faire, utilisez votre passerelle de fichiers.

Erreur : FsxFileSystemAuthenticationFailure

Vous pouvez obtenir un FsxFileSystemAuthenticationFailure message d'erreur lorsque les informations d'identification fournies lors de la connexion au système de fichiers ont expiré ou que ses privilèges ont été révoqués.

Pour résoudre une FsxFileSystemAuthenticationFailure erreur
  1. Assurez-vous que les informations d'identification fournies au moment de joindre le système de fichiers Amazon FSx sont toujours valides.

  2. Assurez-vous que l'utilisateur dispose de toutes les autorisations nécessaires, comme décrit dans Joindre un système de fichiers Amazon FSx pour Windows File Server.

Erreur : FsxFileSystemConnectionFailure

Vous pouvez obtenir un FsxFileSystemConnectionFailure message d'erreur lorsque le serveur Amazon FSx est inaccessible depuis la machine passerelle.

Pour résoudre une FsxFileSystemConnectionFailure erreur
  1. Assurez-vous que toutes les règles de pare-feu et de VPC autorisent la connexion entre la machine passerelle et le serveur Amazon FSx.

  2. Assurez-vous que le serveur Amazon FSx est en cours d'exécution.

Erreur : FsxFileSystemFull

Une FsxFileSystemFull erreur peut s'afficher lorsque l'espace disque disponible dans le système de fichiers Amazon FSx est insuffisant.

Pour résoudre une FsxFileSystemFull erreur
  • Augmentez l'espace de stockage du système de fichiers Amazon FSx.

Erreur : GatewayClockOutOfSync

Vous pouvez obtenir un GatewayClockOutOfSync message d'erreur lorsque la passerelle détecte une différence de 5 minutes ou plus entre l'heure du système local et l'heure indiquée par les serveurs AWS Storage Gateway. Les problèmes de synchronisation de l'horloge peuvent avoir un impact négatif sur la connectivité entre la passerelle et AWS. Si l'horloge de la passerelle n'est pas synchronisée, des I/O erreurs peuvent se produire pour les connexions NFS et SMB, et les utilisateurs SMB peuvent rencontrer des erreurs d'authentification.

Pour résoudre une GatewayClockOutOfSync erreur

Erreur : InvalidFileState

Vous pouvez obtenir une InvalidFileState erreur lorsqu'un rédacteur autre que la passerelle spécifiée modifie le fichier spécifié dans le partage de fichiers spécifié. Par conséquent, l'état du fichier sur la passerelle ne correspond pas à son état dans Amazon FSx. Tout chargement ou extraction ultérieur du fichier depuis Amazon FSx risquait d'échouer.

Pour résoudre une InvalidFileState erreur
  1. Enregistrez la dernière copie du fichier dans le système de fichiers local de votre client SMB (vous aurez besoin de ce fichier à copier à l'étape 4). Si la version du fichier dans Amazon FSx est la plus récente, téléchargez-la. Vous pouvez le faire en accédant directement au partage Amazon FSx à l'aide de n'importe quel client SMB.

  2. Supprimez directement le fichier dans Amazon FSx.

  3. Supprimez le fichier de la passerelle à l'aide de votre client SMB.

  4. À l'aide de votre client SMB, copiez la dernière version du fichier que vous avez enregistré à l'étape 1, via votre File Gateway, sur Amazon FSx.

Erreur : ObjectMissing

Vous pouvez obtenir une ObjectMissing erreur lorsqu'un rédacteur autre que la passerelle de fichiers spécifiée supprime le fichier spécifié d'Amazon FSx. Les chargements ultérieurs vers Amazon FSx ou les extractions depuis Amazon FSx pour l'objet échouent.

Pour résoudre une ObjectMissing erreur
  1. Enregistrez la dernière copie du fichier dans le système de fichiers local de votre client SMB (vous aurez besoin de cette copie de fichier à l'étape 3).

  2. Supprimez le fichier de la passerelle de fichiers à l'aide de votre client SMB.

  3. Copiez la dernière version du fichier que vous avez enregistré à l'étape 1 Amazon FSx à l'aide de votre client SMB. Pour ce faire, utilisez votre passerelle de fichiers.

Erreur : DroppedNotifications

Une DroppedNotifications erreur peut s'afficher à la place des autres types d'entrées de CloudWatch journal attendus lorsque l'espace de stockage disponible sur le disque racine de votre passerelle est inférieur à 1 Go ou si plus de 100 notifications d'état sont générées dans un intervalle d'une minute. Dans ces circonstances, la passerelle cesse de générer des notifications de CloudWatch journal détaillées par mesure de précaution.

Pour résoudre une DroppedNotifications erreur

  1. Consultez la Root Disk Usage métrique de l'onglet Surveillance de votre passerelle dans la console Storage Gateway pour déterminer si l'espace disponible sur le disque racine est insuffisant.

  2. Augmentez la taille du disque de stockage racine de la passerelle si l'espace disponible est inférieur à 1 Go. Reportez-vous à la documentation de l'hyperviseur de votre machine virtuelle pour obtenir des instructions.

    Pour augmenter la taille du disque racine pour les passerelles Amazon EC2, consultez la section Demander des modifications à vos volumes EBS dans le guide de l'utilisateur Amazon Elastic Compute Cloud.

    Note

    Il n'est pas possible d'augmenter la taille du disque racine de l'appliance matérielle AWS Storage Gateway.

  3. Redémarrez la passerelle.

Notification : HardReboot

Vous pouvez obtenir une notification HardReboot lorsque la machine virtuelle de la passerelle est redémarrée de façon inattendue. Un tel redémarrage peut être dû à une perte de puissance, à une défaillance matérielle ou à un autre événement. Pour les passerelles VMware, une réinitialisation par vSphere High Availability Application Monitoring peut provoquer cet événement.

Lorsque votre passerelle s’exécute dans un tel environnement, vérifiez la présence de la notification HealthCheckFailure et consultez le journal des événements VMware pour la machine virtuelle.

Notification : Reboot

Vous pouvez obtenir une notification de redémarrage lorsque la machine virtuelle de la passerelle est redémarrée. Vous pouvez redémarrer une machine virtuelle de passerelle à l’aide de la console de gestion des hyperviseurs de la machine virtuelle ou de la console Storage Gateway. Vous pouvez également la redémarrer à l’aide du logiciel de la passerelle pendant le cycle de maintenance de la passerelle.

Si l'heure du redémarrage se situe dans les 10 minutes de l'heure de démarrage de la maintenance configurée de la passerelle, ce redémarrage est probablement une occurrence normale et non un signe de problème. Si le redémarrage s’est produit largement en dehors de la fenêtre de maintenance, vérifiez si la passerelle a été redémarrée manuellement.

Résolution des problèmes : problèmes liés au domaine Active Directory

FSx File Gateway ne génère pas de messages de journal spécifiques pour les problèmes de domaine Active Directory. Si vous ne parvenez pas à joindre votre passerelle à votre domaine Active Directory, procédez comme suit :

  • Vérifiez que la passerelle n'essaie pas d'utiliser un contrôleur de domaine en lecture seule (RODC) pour rejoindre le domaine.

  • Vérifiez que la passerelle est configurée pour utiliser les serveurs DNS appropriés.

    Par exemple, si vous essayez de joindre une instance de passerelle Amazon EC2 à un Active Directory AWS géré, vérifiez que l'option DHCP définie pour votre VPC EC2 spécifie les AWS serveurs DNS Active Directory gérés.

    Les serveurs DNS que vous configurez via le jeu d'options DHCP du VPC sont fournis à toutes les instances EC2 du VPC. Si vous souhaitez spécifier un serveur DNS pour une passerelle individuelle, vous pouvez le faire à l'aide de la console locale EC2 de cette passerelle.

    Pour les passerelles locales, vous spécifiez un serveur DNS à l'aide de la console locale de la machine virtuelle.

  • Vérifiez la connectivité réseau de la passerelle en exécutant les commandes suivantes depuis l'invite de commande de la console locale de la passerelle. Remplacez les variables surlignées par le nom de domaine et les adresses IP réels de votre déploiement.

    dig -d ExampleDomainName ncport -d ExampleDomainControllerIPAddress -p 445 ncport -d ExampleDomainControllerIPAddress -p 389
  • Vérifiez que votre compte de service Active Directory dispose des autorisations requises. Pour plus d'informations, voir Active Directory Exigences d'autorisation du compte de service Active Directory.

  • Vérifiez que la passerelle rejoint l'unité organisationnelle (UO) appropriée.

    L'adhésion à un domaine crée un compte d'ordinateur Active Directory dans le conteneur d'ordinateurs par défaut (qui n'est pas une unité d'organisation), en utilisant l'ID de passerelle de la passerelle comme nom de compte (par exemple, SGW-1234ADE). Il n'est pas possible de personnaliser le nom de ce compte.

    Si votre environnement Active Directory possède une unité d'organisation désignée pour les nouveaux objets informatiques, vous devez spécifier cette unité d'organisation lorsque vous rejoignez le domaine.

    Si vous rencontrez des erreurs d'accès refusé lorsque vous tentez de rejoindre l'unité d'organisation désignée, contactez votre administrateur de domaine Active Directory. L'administrateur peut avoir besoin de pré-configurer le compte informatique de la passerelle avant que celle-ci puisse rejoindre le domaine. Pour plus d'informations, voir Comment résoudre les problèmes liés à l'association de ma passerelle de fichiers Storage Gateway à un domaine pour l'authentification Microsoft Active Directory ? .

  • Vérifiez que le nom d'hôte de votre passerelle peut être résolu dans le DNS en exécutant la commande suivante depuis l'invite de commande de la console locale de la passerelle. Remplacez la variable surlignée par le nom d'hôte réel de votre passerelle.

    dig -d ExampleHostName -r A

    Si vous avez configuré un nom d'hôte personnalisé pour votre passerelle, vous devez ajouter manuellement un DNS A-record qui pointe vers son adresse IP.

  • Vérifiez que la latence réseau entre la passerelle et le contrôleur de domaine est raisonnablement faible. La requête pour rejoindre un domaine peut exérer si la passerelle ne reçoit pas de réponse du contrôleur de domaine dans les 20 secondes.

    Si vous connectez la passerelle au domaine à l'aide de la commande JoinDomain CLI, vous pouvez ajouter l'--timeout-in-secondsindicateur pour augmenter le délai d'attente jusqu'à 3 600 secondes maximum.

  • Vérifiez que l'utilisateur Active Directory que vous utilisez pour rejoindre la passerelle vers le domaine dispose des privilèges requis pour le faire.

Résolution des problèmes : utilisation de CloudWatch métriques

Vous trouverez ci-dessous des informations sur les mesures à prendre pour résoudre les problèmes liés à l'utilisation CloudWatch des métriques Amazon avec Storage Gateway.

Votre passerelle réagit lentement lorsque vous parcourez les annuaires

Si votre passerelle de fichiers réagit lentement lorsque vous exécutez la ls commande ou que vous parcourez des répertoires, vérifiez les IndexEviction CloudWatch indicateurs IndexFetch et :

  • Si la IndexFetch métrique est supérieure à 0 lorsque vous exécutez une ls commande ou que vous parcourez des répertoires, votre passerelle de fichiers a démarré sans informations sur le contenu du répertoire concerné et a dû accéder à FSx pour Windows File Server. Les opérations ultérieures pour répertorier le contenu de ce répertoire devraient s'exécuter plus rapidement.

  • Si la IndexEviction métrique est supérieure à 0, cela signifie que votre passerelle de fichiers a atteint la limite de ce qu'elle peut gérer dans son cache à ce moment-là. Dans ce cas, votre passerelle de fichiers doit libérer de l'espace de stockage dans le répertoire le moins récemment consulté pour répertorier un nouveau répertoire. Si cela se produit fréquemment et que cela a un impact sur les performances, contactez Support.

    Discutez Support du contenu du système de fichiers Amazon FSx associé et des recommandations pour améliorer les performances en fonction de votre cas d'utilisation.

Votre passerelle ne répond pas

Si votre passerelle de fichiers ne répond pas, procédez comme suit :

  • Dans le cas d'une mise à jour logicielle ou d’un redémarrage récent, vérifiez la métrique IOWaitPercent. Cette métrique indique le pourcentage de temps pendant lequel le processeur est inactif lorsqu'une I/O demande de disque est en attente. Dans certains cas, ce pourcentage peut être élevé (10 ou plus) et peut avoir augmenté après le redémarrage ou la mise à jour du serveur. Dans ces cas, votre passerelle de fichiers peut être bloquée par un disque racine lent alors qu'elle reconstruit le cache d'index en RAM. Vous pouvez résoudre ce problème en utilisant un disque physique plus rapide pour le disque racine.

  • Si la MemUsedBytes métrique est égale ou presque identique à la MemTotalBytes métrique, cela signifie que votre passerelle de fichiers est à court de RAM disponible. Assurez-vous que votre passerelle de fichiers dispose au moins de la RAM minimale requise. Si c'est déjà le cas, pensez à ajouter de la RAM à votre passerelle de fichiers en fonction de votre charge de travail et de votre cas d'utilisation.

    Si le partage de fichiers est SMB, le problème peut également être dû au nombre de clients SMB connectés au partage de fichiers. Pour connaître le nombre de clients connectés à un moment donné, vérifiez la métrique SMBV(1/2/3)Sessions. Si de nombreux clients sont connectés, il se peut que vous deviez ajouter de la RAM à votre passerelle de fichiers.

Les fichiers ne s'affichent pas dans votre système de fichiers Amazon FSx

Si vous remarquez que les fichiers de la passerelle ne sont pas reflétés dans le système de fichiers Amazon FSx, vérifiez la FilesFailingUpload métrique. Si la métrique indique que le chargement de certains fichiers échoue, vérifiez vos notifications de santé. Lorsque les fichiers ne sont pas chargés, la passerelle génère une notification de santé contenant plus de détails sur le problème.

Les anciens instantanés ne figurent pas dans votre système de fichiers Amazon FSx

Certaines opérations sur les fichiers sur la passerelle de fichiers FSx, telles que le renommage des dossiers de niveau supérieur ou la modification des autorisations, peuvent entraîner de multiples opérations sur les fichiers qui entraînent une I/O charge élevée sur votre système de fichiers FSx pour Windows File Server. Si votre système de fichiers ne dispose pas de ressources de performance suffisantes pour votre charge de travail, il peut supprimer les clichés instantanés car il donne la priorité à la disponibilité des clichés instantanés par I/O rapport à la conservation historique des clichés instantanés.

Dans la console Amazon FSx, consultez la page Surveillance et performances pour voir si votre système de fichiers est sous-provisionné. Si c'est le cas, vous pouvez passer au stockage SSD, augmenter la capacité de débit ou augmenter les IOPS SSD pour gérer votre charge de travail.

Votre passerelle est lente à transférer des données vers Amazon FSx

Si votre passerelle de fichiers est lente à transférer des données vers Amazon FSx pour Windows File Server, procédez comme suit :

  • Si la CachePercentDirty métrique est supérieure ou égale à 80, votre File Gateway écrit les données sur le disque plus rapidement qu'elle ne peut les télécharger sur Amazon FSx pour Windows File Server. Envisagez d'augmenter la bande passante pour le téléchargement depuis votre passerelle de fichiers, d'ajouter un ou plusieurs disques de cache, de ralentir les écritures des clients ou d'augmenter la capacité de débit du serveur de fichiers Amazon FSx pour Windows associé.

  • Si la CachePercentDirty métrique est faible, IoWaitPercent vérifiez-la. Si IoWaitPercent cette valeur est supérieure à 10, votre passerelle de fichiers est peut-être bloquée par la vitesse du disque cache local. Nous recommandons des disques SSD (Solid State Drive) locaux pour votre cache, de préférence NVM Express (NVMe). Si de tels disques ne sont pas disponibles, essayez d'utiliser plusieurs disques de cache provenant de disques physiques distincts pour améliorer les performances.

La tâche de sauvegarde de votre passerelle échoue ou des erreurs se produisent lors de l'écriture sur votre passerelle

Si votre tâche de sauvegarde de File Gateway échoue ou si des erreurs surviennent lors de l'écriture sur votre File Gateway, procédez comme suit :

  • Si la CachePercentDirty métrique est supérieure ou égale à 90 %, votre passerelle de fichiers ne peut pas accepter de nouvelles écritures sur le disque car l'espace disponible sur le disque cache est insuffisant. Pour connaître la rapidité avec laquelle votre passerelle de fichiers est chargée vers FSx pour Windows File Server, consultez la CloudBytesUploaded métrique. Comparez cette métrique à la WriteBytes métrique, qui indique la rapidité avec laquelle le client écrit des fichiers sur votre File Gateway. Si le client SMB écrit sur votre File Gateway plus rapidement qu'il ne peut le télécharger FSx pour Windows File Server, ajoutez des disques de cache supplémentaires pour couvrir au minimum la taille de la tâche de sauvegarde. Vous pouvez également augmenter la bande passante de chargement.

  • Si une copie de fichier volumineuse, telle qu'une tâche de sauvegarde, échoue mais que la CachePercentDirty métrique est inférieure à 80 %, il se peut que votre passerelle de fichiers atteigne un délai d'expiration de session côté client. Pour SMB, vous pouvez augmenter ce délai à l'aide de la PowerShell commande. Set-SmbClientConfiguration -SessionTimeout 300 L'exécution de cette commande définit le délai d'expiration à 300 secondes.