View a markdown version of this page

Solución de problemas: problemas con la puerta de enlace de archivo - AWS Storage Gateway

La puerta de enlace de archivo de Amazon FSx ya no está disponible para los nuevos clientes. Los clientes existentes de la puerta de enlace de archivo de FSx pueden seguir utilizando el servicio con normalidad. Para obtener información sobre capacidades similares a la puerta de enlace de archivo de FSx, consulte esta entrada del blog.

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Solución de problemas: problemas con la puerta de enlace de archivo

Puede configurar su File Gateway para escribir entradas de registro en un grupo de CloudWatch registros de Amazon. Si lo hace, recibirá notificaciones acerca del estado de la puerta de enlace y de los errores que esta detecta. Puedes encontrar información sobre estas notificaciones de error y estado en CloudWatch los registros.

En las siguientes secciones puede encontrar información que le ayudará a comprender la causa de cada notificación de estado y error y cómo solucionar los problemas.

Error: FileMissing

El error FileMissing es similar al error ObjectMissing y los pasos para resolverlo son idénticos. Se puede detectar un error FileMissing cuando un escritor que no sea la puerta de enlace de archivo especificada elimina el archivo especificado de Amazon FSx. Cualquier carga posterior en Amazon FSx o recuperación desde Amazon FSx del objeto fallará.

Para resolver un FileMissing error
  1. Guarde la copia más reciente del archivo en el sistema de archivos local del cliente SMB (necesitará una copia del archivo en el paso 3).

  2. Elimine el archivo de la puerta de enlace de archivo utilizando el cliente SMB.

  3. Copie la última versión del archivo que ha guardado en Amazon FSx en el paso 1 utilizando el cliente SMB. Haga esto mediante la puerta de enlace de archivo.

Error: FsxFileSystemAuthenticationFailure

Se puede producir un error FsxFileSystemAuthenticationFailure cuando las credenciales proporcionadas al asociar el sistema de archivos hayan caducado o se hayan revocado sus privilegios.

Para resolver un FsxFileSystemAuthenticationFailure error
  1. Asegúrese de que las credenciales proporcionadas al asociar el sistema de archivos de Amazon FSx siguen siendo válidas.

  2. Asegúrese de que el usuario tiene todos los permisos necesarios, tal y como se describe en Asociar un sistema de archivos de Amazon FSx para Windows File Server.

Error: FsxFileSystemConnectionFailure

Puede producirse un error FsxFileSystemConnectionFailure si no se puede acceder al servidor de Amazon FSx desde la máquina de puerta de enlace.

Para resolver un FsxFileSystemConnectionFailure error
  1. Asegúrese de que todas las reglas de firewall y VPC permitan la conexión entre la máquina de puerta de enlace y el servidor de Amazon FSx.

  2. Compruebe que el servidor de Amazon FSx esté en ejecución.

Error: FsxFileSystemFull

Puede producirse un error FsxFileSystemFull si no hay suficiente espacio libre en disco en el sistema de archivos de Amazon FSx.

Para resolver un FsxFileSystemFull error
  • Aumente el espacio de almacenamiento del sistema de archivos de Amazon FSx.

Error: GatewayClockOutOfSync

Es posible que aparezca un GatewayClockOutOfSync error cuando la puerta de enlace detecte una diferencia de 5 minutos o más entre la hora del sistema local y la hora indicada por los servidores de AWS Storage Gateway. Los problemas de sincronización del reloj pueden afectar negativamente a la conectividad entre la puerta de enlace y AWS. Si el reloj de la puerta de enlace no está sincronizado, es posible que se produzcan I/O errores en las conexiones NFS y SMB, y los usuarios de pequeñas y medianas empresas pueden experimentar errores de autenticación.

Para resolver un error GatewayClockOutOfSync

Error: InvalidFileState

Se puede detectar un error InvalidFileState cuando un escritor que no sea la puerta de enlace especificada modifica el archivo especificado en el recurso compartido de archivos especificado. Como resultado, el estado del archivo de la puerta de enlace no coincide con su estado en Amazon FSx. Cualquier carga posterior del archivo en Amazon FSx o recuperación del archivo desde Amazon FSx fallará.

Para resolver un InvalidFileState error
  1. Guarde la copia más reciente del archivo en el sistema de archivos local del cliente SMB (necesitará una copia del archivo en el paso 4). Si la versión del archivo que se encuentra en Amazon FSx es la más reciente, descárguela. Puede hacerlo accediendo directamente al recurso compartido de Amazon FSx mediante cualquier cliente SMB.

  2. Elimine el archivo directamente en Amazon FSx.

  3. Elimine el archivo de la puerta de enlace utilizando el cliente SMB.

  4. Utilizando el cliente SMB, copie la última versión del archivo que guardó en el paso 1, a través de la puerta de enlace de archivo, en Amazon FSx.

Error: ObjectMissing

Se puede detectar un error ObjectMissing cuando un escritor que no sea la puerta de enlace de archivo especificada elimina el archivo especificado de Amazon FSx. Cualquier carga posterior en Amazon FSx o recuperación desde Amazon FSx del objeto fallará.

Para resolver un ObjectMissing error
  1. Guarde la copia más reciente del archivo en el sistema de archivos local del cliente SMB (necesitará una copia del archivo en el paso 3).

  2. Elimine el archivo de la puerta de enlace de archivo utilizando el cliente SMB.

  3. Copie la última versión del archivo que ha guardado en Amazon FSx en el paso 1 utilizando el cliente SMB. Haga esto mediante la puerta de enlace de archivo.

Error: DroppedNotifications

Es posible que aparezca un DroppedNotifications error en lugar de otros tipos de entradas de CloudWatch registro habituales cuando el espacio de almacenamiento libre en el disco raíz de la puerta de enlace sea inferior a 1 GB o si se generan más de 100 notificaciones de estado en un intervalo de 1 minuto. En estas circunstancias, la puerta de enlace deja de generar notificaciones de CloudWatch registro detalladas como medida de precaución.

Para resolver un DroppedNotifications error

  1. Compruebe la métrica Root Disk Usage de la pestaña Supervisión de la puerta de enlace en la consola de Storage Gateway para determinar si el espacio disponible en el disco raíz se está agotando.

  2. Aumente el tamaño del disco de almacenamiento raíz de la puerta de enlace si el espacio disponible es inferior a 1 GB. Consulte la documentación del hipervisor de la máquina virtual para obtener instrucciones.

    Para aumentar el tamaño del disco raíz de las puertas de enlace de Amazon EC2, consulte Solicitar modificaciones a los volúmenes de EBS en la Guía del usuario de Amazon Elastic Compute Cloud.

    nota

    No es posible aumentar el tamaño del disco raíz del dispositivo de hardware de AWS Storage Gateway.

  3. Reinicie la gateway.

Notificación: HardReboot

Puede recibir una notificación HardReboot cuando la MV de la gateway se reinicia de forma inesperada. Este reinicio se puede deber a una pérdida de potencia, un fallo de hardware u otro evento. En las puertas de enlace de VMware, un reinicio provocado por la supervisión de aplicaciones de alta disponibilidad de vSphere puede producir este evento.

Cuando la gateway se ejecuta en dicho entorno, compruebe si hay notificaciones HealthCheckFailure y consulte el registro de eventos de VMware para la MV.

Notificación: reinicio

Puede recibir una notificación de reinicio cuando la MV de la gateway se reinicia. Puede reiniciar la VM de una puerta de enlace mediante la consola de gestión de hipervisor de VM o la consola de Storage Gateway. También puede llevar a cabo el reinicio de la gateway mediante el software de la gateway durante el ciclo de mantenimiento de la gateway.

Si la hora del reinicio se encuentra dentro de un periodo de 10 minutos desde la hora de inicio de mantenimiento configurada de la gateway, es probable que este reinicio sea un evento normal y no sea signo de ningún problema. Si el reinicio se produce significativamente fuera del periodo de mantenimiento, compruebe si la gateway se ha reiniciado de forma manual.

Solución de problemas: problemas relacionados con el dominio de Active Directory

La puerta de enlace de archivo de FSx no genera mensajes de registro específicos para problemas relacionados con el dominio de Active Directory. Si tiene problemas para unir la puerta de enlace al dominio de Active Directory, haga lo siguiente:

  • Compruebe que la puerta de enlace no esté intentando utilizar un controlador de dominio de solo lectura (RODC) para unirse al dominio.

  • Compruebe que la puerta de enlace está configurada para utilizar los servidores DNS correctos.

    Por ejemplo, si está intentando unir una instancia de puerta de enlace de Amazon EC2 a un Active Directory AWS administrado, compruebe que la opción de DHCP configurada para su VPC de EC2 especifique los servidores DNS de Active Directory AWS administrados.

    Los servidores DNS que se configuran mediante el conjunto de opciones de DHCP de la VPC se proporcionan a todas las instancias de EC2 de la VPC. Si desea especificar un servidor DNS para una puerta de enlace individual, puede hacerlo mediante la consola local EC2 de esa puerta de enlace.

    Para las puertas de enlace en las instalaciones, especifique un servidor DNS mediante la consola local de la máquina virtual.

  • Compruebe la conectividad de la red de la puerta de enlace ejecutando los siguientes comandos desde el símbolo del sistema de la consola local de la puerta de enlace. Sustituya las variables resaltadas por el nombre de dominio y las direcciones IP reales de la implementación.

    dig -d ExampleDomainName ncport -d ExampleDomainControllerIPAddress -p 445 ncport -d ExampleDomainControllerIPAddress -p 389
  • Compruebe que su cuenta de servicio de Active Directory tenga los permisos necesarios. Para obtener más información, consulte Requisitos de permiso de la cuenta de servicio de Active Directory.

  • Compruebe que la puerta de enlace se une a la unidad organizativa (UO) correcta.

    Al unirse a un dominio, se crea una cuenta de computadora de Active Directory en el contenedor de computadoras predeterminado (que no es una unidad organizativa), utilizando el ID de puerta de enlace de la puerta de enlace como nombre de la cuenta (por ejemplo,). SGW-1234ADE No es posible personalizar el nombre de esta cuenta.

    Si su entorno de Active Directory tiene una unidad organizativa designada para los nuevos objetos de equipo, debe especificarla al unirse al dominio.

    Si encuentra errores de denegación de acceso al intentar unirse a la UO designada, póngase en contacto con el administrador del dominio de Active Directory. Es posible que el administrador necesite preparar la cuenta de equipo de la puerta de enlace antes de que pueda unirse al dominio. Para obtener más información, consulte ¿Cómo puedo solucionar problemas relacionados con la unión de la puerta de enlace de archivo de Storage Gateway a un dominio para la autenticación de Microsoft Active Directory? .

  • Compruebe que el nombre de host de la puerta de enlace se pueda resolver en el DNS ejecutando el siguiente comando desde el símbolo del sistema de la consola local de la puerta de enlace. Sustituya la variable resaltada por el nombre de host real de la puerta de enlace.

    dig -d ExampleHostName -r A

    Si configuró un nombre de host personalizado para la puerta de enlace, debe agregar manualmente un DNS A-record que apunte a su dirección IP.

  • Compruebe que la latencia de la red entre la puerta de enlace y el controlador de dominio sea razonablemente baja. El tiempo de espera para la consulta de unión a un dominio puede agotarse si la puerta de enlace no recibe una respuesta del controlador de dominio en 20 segundos.

    Si une la puerta de enlace al dominio mediante el comando de la JoinDomain CLI, puede agregar la --timeout-in-seconds marca para aumentar el tiempo de espera a un máximo de 3.600 segundos.

  • Compruebe que el usuario de Active Directory que está utilizando para unir la puerta de enlace al dominio tenga los privilegios necesarios para hacerlo.

Solución de problemas: uso de métricas CloudWatch

A continuación encontrarás información sobre las medidas que puedes tomar para solucionar problemas al utilizar CloudWatch las métricas de Amazon con Storage Gateway.

La puerta de enlace reacciona lentamente al examinar directorios

Si tu File Gateway reacciona con lentitud cuando ejecutas el ls comando o navegas por los directorios, comprueba las IndexEviction CloudWatch métricas IndexFetch y:

  • Si la métrica IndexFetch es mayor que 0 cuando ejecuta un comando ls o examina directorios, la puerta de enlace de archivo se ha iniciado sin información acerca del contenido del directorio afectado y ha tenido que acceder a FSx para Windows File Server. Los esfuerzos posteriores para mostrar el contenido de ese directorio deberían realizarse más rápidamente.

  • Si la métrica de IndexEviction es mayor que 0, significa que la puerta de enlace de archivo ha alcanzado el límite de lo que puede gestionar en la caché en ese momento. En este caso, la puerta de enlace de archivo tiene que liberar espacio de almacenamiento del directorio al que se ha accedido menos recientemente para crear un nuevo directorio. Si esto ocurre con frecuencia y hay un impacto en el rendimiento, póngase en contacto con Soporte.

    Hable con usted sobre Soporte el contenido del sistema de archivos Amazon FSx relacionado y sobre las recomendaciones para mejorar el rendimiento en función de su caso práctico.

La puerta de enlace no responde

Si la puerta de enlace de archivo no responde, realice las siguientes acciones:

  • Si se ha producido una actualización de software o un reinicio recientemente, compruebe la métrica IOWaitPercent. Esta métrica muestra el porcentaje de tiempo que la CPU permanece inactiva cuando hay una I/O solicitud de disco pendiente. En algunos casos, puede ser elevado (10 o más) y se puede producir después de que el servidor se haya reiniciado o actualizado. En estos casos, se puede producir un efecto embudo en la puerta de enlace de archivo a causa de un disco raíz lento, ya que reanuda la caché de índice en la RAM. Puede solucionar este problema mediante el uso de un disco físico más rápido para el disco raíz.

  • Si la métrica MemUsedBytes es igual o prácticamente igual que la métrica MemTotalBytes, la puerta de enlace de archivo se está ejecutando fuera de la RAM disponible. Asegúrese de que la puerta de enlace de archivo tenga el menos la RAM mínima requerida. Si ya la tiene, considere añadir más RAM a la puerta de enlace de archivo en función de la carga de trabajo y el caso de uso.

    Si el recurso compartido de archivos es SMB, el problema también podría deberse al número de clientes SMB conectados a dicho recurso. Para ver el número de clientes que están conectados en cualquier momento, compruebe la métrica SMBV(1/2/3)Sessions. Si hay muchos clientes conectados, es posible que necesite añadir más RAM a la puerta de enlace de archivo.

No ve archivos en el sistema de archivos de Amazon FSx

Si observa que los archivos de la puerta de enlace no se reflejan en el sistema de archivos de Amazon FSx, compruebe la métrica FilesFailingUpload. Si la métrica indica que algunos archivos no se cargan correctamente, compruebe las notificaciones de estado. Cuando los archivos no se pueden cargar, la puerta de enlace genera una notificación de salud con más detalles sobre el problema.

No ve instantáneas antiguas en el sistema de archivos de Amazon FSx

Algunas operaciones con archivos en la pasarela de archivos FSx, como los cambios de nombre de carpetas de nivel superior o los cambios de permisos, pueden provocar múltiples operaciones con archivos y provocar una I/O carga elevada en el sistema de archivos del servidor de archivos FSx para Windows. Si su sistema de archivos no tiene suficientes recursos de rendimiento para su carga de trabajo, es posible que el sistema de archivos elimine las instantáneas porque prioriza la disponibilidad para la retención continua sobre I/O la histórica.

En la consola de Amazon FSx, consulte la página Supervisión y rendimiento para comprobar si su sistema de archivos dispone de poco aprovisionamiento. Si es así, puede cambiar a un almacenamiento en SSD, aumentar la capacidad de rendimiento o aumentar las IOPS en SSD para gestionar su carga de trabajo.

La puerta de enlace transfiere datos lentamente a Amazon FSx

Si la puerta de enlace de archivo transfiere datos lentamente a Amazon FSx para Windows File Server, haga lo siguiente:

  • Si la métrica CachePercentDirty es 80 o superior, la puerta de enlace de archivo escribe los datos en el disco a una velocidad más rápida de la que puede utilizar para cargar los datos en Amazon FSx para Windows File Server. Considere la posibilidad de aumentar el ancho de banda para la carga desde la puerta de enlace de archivo, añadir uno o más discos de caché, ralentizar las escrituras de los clientes o aumentar la capacidad de rendimiento del Amazon FSx para Windows File Server asociado.

  • Si la métrica CachePercentDirty es baja, compruebe la métrica IoWaitPercent. Si IoWaitPercent es mayor que 10, es posible que se produzca un efecto embudo en la puerta de enlace de archivo por la velocidad del disco en caché local. Recomendamos el uso de discos locales de unidades de estado sólido (SSD) para la caché, preferiblemente NVM Express (NVMe). Si dichos discos no están disponibles, intente utilizar varios discos en caché desde discos físicos independientes para mejorar el rendimiento.

El trabajo de copia de seguridad de la puerta de enlace falla o se producen errores al escribir en la puerta de enlace

Si el trabajo de copia de seguridad de la puerta de enlace de archivo falla o se producen errores al escribir en la puerta de enlace de archivo, realice las siguientes acciones:

  • Si la métrica CachePercentDirty es del 90 por ciento o superior, la puerta de enlace de archivo no puede aceptar nuevas escrituras en el disco porque no hay suficiente espacio disponible en el disco de caché. Para ver la rapidez con la que su puerta de enlace de archivo se carga en FSx para Windows File Server, consulte la métrica CloudBytesUploaded. Compare esa métrica con la métrica WriteBytes, que muestra a qué velocidad escribe archivos el cliente en la puerta de enlace de archivo. Si el cliente de SMB escribe en la puerta de enlace de archivo a una velocidad más rápida de la que puede utilizar para realizar cargas en FSx para Windows File Server, añada más discos de caché para cubrir el tamaño del trabajo de copia de seguridad como mínimo. También puede aumentar el ancho de banda de carga.

  • Si una copia de un archivo grande como un trabajo de copia de seguridad falla, pero la métrica CachePercentDirty es inferior al 80 por ciento, es posible que la puerta de enlace de archivo esté alcanzando el tiempo de espera de la sesión del lado del cliente. En el caso de las pequeñas y medianas empresas, puedes aumentar este tiempo de espera con el comando. PowerShell Set-SmbClientConfiguration -SessionTimeout 300 Al ejecutar este comando, el tiempo de espera se establece en 300 segundos.