View a markdown version of this page

Solucionar problemas de una fuente ServiceNow de datos - Amazon Bedrock

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Solucionar problemas de una fuente ServiceNow de datos

Utilice esta página para diagnosticar problemas comunes relacionados con la ServiceNow autenticación y la sincronización.

Errores de autenticación y acceso a la API

En la siguiente tabla se describen los errores comunes de autenticación y acceso a la API, sus causas probables y cómo solucionarlos.

Errores de autenticación y acceso a la API
Síntoma Causa probable Fix
La API de tabla devuelve el protocolo HTTP 401 aunque la solicitud del token se realice correctamente. El perfil de autenticación entrante no está vinculado a la política de acceso a la API REST o la política de permiso de acceso no se agregó al perfil. Verifique ambos lados de la configuración de la política de acceso a la API. Consulte Paso 6: Configurar las políticas de acceso a la API.
La sincronización finaliza, pero se notifica que se han rastreado 0 documentos. La cuenta de servicio tiene la catalog función básica knowledge o en lugar de knowledge_admin ocatalog_admin. Asigne knowledge_admin y catalog_admin a la cuenta de servicio. Consulte Paso 3: Asignar funciones a la cuenta de servicio.
La solicitud del token falla o el conector no puede llegar a tu instancia. La propiedad glide.oauth.inbound.client.credential.grant_type.enabled del sistema no está configurada en o no se puede acceder a true la instancia desde AWS. Verifique la propiedad del sistema y la conectividad de la red. Consulte Paso 1: Habilite el tipo de concesión de credenciales de cliente.

Rendimiento de sincronización

En la tabla siguiente se describe un problema común de rendimiento de la sincronización y cómo solucionarlo.

Problemas de rendimiento de sincronización
Síntoma Causa probable Fix
La sincronización tarda horas en instancias grandes. No hay ningún filtro de ID de catálogo configurado, por lo que el conector rastrea todos los elementos del catálogo activos (100 000 o más en las instancias empresariales). Usa serviceCatalogFilter (withinclusionServiceCatalogSysIds) in filterConfiguration para restringir el rastreo a catálogos de servicios específicos. Consulte Parámetros de conector.