View a markdown version of this page

Seeing kann das Gebietsschema (en_US.utf-8) nicht ändern, da es einen ungültigen Namen in hat slurm_resume.log - AWS ParallelCluster

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

Seeing kann das Gebietsschema (en_US.utf-8) nicht ändern, da es einen ungültigen Namen in hat slurm_resume.log

Dies kann auftreten, wenn bei der yum Installation ein inkonsistenter Zustand der Gebietsschemaeinstellungen aufgetreten ist. Dies kann beispielsweise verursacht werden, wenn ein Benutzer den Installationsvorgang beendet.

Gehen Sie wie folgt vor, um die Ursache zu überprüfen:
  • Führen Sie su - pcluster-admin.

    Die Shell zeigt einen Fehler an, cannot change locale...no such file or directory z. B.

  • Führen Sie localedef --list.

    Gibt eine leere Liste zurück oder enthält nicht das Standardgebietsschema.

  • Überprüfen Sie den letzten yum Befehl mit yum history undyum history info #ID. Hat die letzte IDReturn-Code: Success?

    Wenn die letzte ID nicht vorhanden istReturn-Code: Success, wurden die Skripts nach der Installation möglicherweise nicht erfolgreich ausgeführt.

Versuchen Sie, das Gebietsschema mit neu aufzubauen, um das Problem zu beheben. yum reinstall glibc-all-langpacks Nach dem Neuaufbau su - pcluster-admin wird kein Fehler oder keine Warnung angezeigt, wenn das Problem behoben ist.