Amazon FSx File Gateway ist für Neukunden nicht mehr verfügbar. Bestehende Kunden von FSx File Gateway können den Service weiterhin normal nutzen. Informationen zu ähnlichen Funktionen wie FSx File Gateway finden Sie in diesem Blogbeitrag.
Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.
Problembehandlung: Probleme mit dem File Gateway
Sie können Ihr File Gateway so konfigurieren, dass Logeinträge in eine CloudWatch Amazon-Loggruppe geschrieben werden. Wenn Sie dies tun, erhalten Sie Benachrichtigungen über den Integritätsstatus des Gateways und über alle Fehler, auf die das Gateway stößt. Informationen zu diesen Fehler- und Zustandsbenachrichtigungen finden Sie in den CloudWatch Protokollen.
In den folgenden Abschnitten finden Sie Informationen, die Ihnen helfen können, die Ursache der einzelnen Fehler- und Zustandsbenachrichtigungen zu verstehen und Probleme zu beheben.
Themen
Fehler: FileMissing
Der FileMissing Fehler ähnelt dem ObjectMissing Fehler, und die Schritte zur Behebung sind identisch. Es kann zu einer FileMissing Fehlermeldung kommen, wenn ein anderer Writer als das angegebene File Gateway die angegebene Datei aus dem Amazon FSx löscht. Alle nachfolgenden Uploads auf Amazon FSx oder Abrufe von Amazon FSx für das Objekt schlagen fehl.
FileMissing Um einen Fehler zu beheben
-
Speichern Sie die neueste Kopie der Datei im lokalen Dateisystem Ihres SMB-Clients (Sie benötigen diese Dateikopie in Schritt 3).
-
Löschen Sie die Datei mit Ihrem SMB-Client aus dem File Gateway.
-
Kopieren Sie die neueste Version der Datei, die Sie in Schritt 1 Amazon FSx gespeichert haben, mit Ihrem SMB-Client. Tun Sie dies über Ihr File Gateway.
Fehler: FsxFileSystemAuthenticationFailure
Sie können eine FsxFileSystemAuthenticationFailure Fehlermeldung erhalten, wenn die beim Anhängen des Dateisystems angegebenen Anmeldeinformationen abgelaufen sind oder die Rechte entzogen wurden.
Um einen Fehler zu beheben FsxFileSystemAuthenticationFailure
-
Stellen Sie sicher, dass die beim Anhängen des Amazon FSx-Dateisystems angegebenen Anmeldeinformationen weiterhin gültig sind.
-
Stellen Sie sicher, dass der Benutzer über alle erforderlichen Berechtigungen verfügt, wie unter Anhängen eines Dateisystems von Amazon FSx für Windows beschrieben.
Fehler: FsxFileSystemConnectionFailure
Sie können eine FsxFileSystemConnectionFailure Fehlermeldung erhalten, wenn vom Gateway-Computer aus nicht auf den Amazon FSx-Server zugegriffen werden kann.
Um einen Fehler zu beheben FsxFileSystemConnectionFailure
-
Stellen Sie sicher, dass alle Firewall- und VPC-Regeln die Verbindung zwischen dem Gateway-Computer und dem Amazon FSx-Server zulassen.
-
Stellen Sie sicher, dass der Amazon FSx-Server läuft.
Fehler: FsxFileSystemFull
Sie können eine FsxFileSystemFull Fehlermeldung erhalten, wenn im Amazon FSx-Dateisystem nicht genügend freier Speicherplatz vorhanden ist.
Um einen Fehler zu beheben FsxFileSystemFull
-
Erhöhen Sie den Speicherplatz für das Amazon FSx-Dateisystem.
Fehler: GatewayClockOutOfSync
Es kann eine GatewayClockOutOfSync Fehlermeldung auftreten, wenn das Gateway einen Unterschied von 5 Minuten oder mehr zwischen der lokalen Systemzeit und der von den AWS Storage Gateway-Servern gemeldeten Zeit feststellt. Probleme mit der Uhrsynchronisierung können sich negativ auf die Konnektivität zwischen dem Gateway und auswirken AWS. Wenn die Gateway-Uhr nicht synchron ist, können I/O Fehler bei NFS- und SMB-Verbindungen auftreten, und bei SMB-Benutzern treten möglicherweise Authentifizierungsfehler auf.
Um einen Fehler zu beheben GatewayClockOutOfSync
-
Überprüfen Sie die Netzwerkkonfiguration zwischen dem Gateway und dem NTP-Server. Weitere Informationen zum Synchronisieren der Gateway-VM-Zeit und zum Aktualisieren der NTP-Serverkonfiguration finden Sie unter Konfigurieren eines Network Time Protocol (NTP) -Servers für Ihr Gateway.
Fehler: InvalidFileState
Es kann zu einer InvalidFileState Fehlermeldung kommen, wenn ein anderer Writer als das angegebene Gateway die angegebene Datei in der angegebenen Dateifreigabe ändert. Daher stimmt der Status der Datei auf dem Gateway nicht mit dem Status in Amazon FSx überein. Alle nachfolgenden Uploads oder Abrufe der Datei von Amazon FSx könnten fehlschlagen.
Um einen Fehler zu beheben InvalidFileState
-
Speichern Sie die neueste Kopie der Datei im lokalen Dateisystem Ihres SMB-Clients (Sie benötigen diese Datei zum Kopieren in Schritt 4). Wenn die Version der Datei in Amazon FSx die neueste ist, laden Sie diese Version herunter. Sie können dies tun, indem Sie mit einem beliebigen SMB-Client direkt auf die Amazon FSx-Freigabe zugreifen.
-
Löschen Sie die Datei direkt in Amazon FSx.
-
Löschen Sie die Datei mit Ihrem SMB-Client vom Gateway.
-
Kopieren Sie mit Ihrem SMB-Client die neueste Version der Datei, die Sie in Schritt 1 gespeichert haben, über Ihr File Gateway nach Amazon FSx.
Fehler: ObjectMissing
Sie können eine ObjectMissing Fehlermeldung erhalten, wenn ein anderer Writer als der angegebene File Gateway die angegebene Datei aus dem Amazon FSx löscht. Alle nachfolgenden Uploads auf Amazon FSx oder Abrufe von Amazon FSx für das Objekt schlagen fehl.
ObjectMissing Um einen Fehler zu beheben
-
Speichern Sie die neueste Kopie der Datei im lokalen Dateisystem Ihres SMB-Clients (Sie benötigen diese Dateikopie in Schritt 3).
-
Löschen Sie die Datei mit Ihrem SMB-Client aus dem File Gateway.
-
Kopieren Sie die neueste Version der Datei, die Sie in Schritt 1 Amazon FSx gespeichert haben, mit Ihrem SMB-Client. Tun Sie dies über Ihr File Gateway.
Fehler: DroppedNotifications
Wenn der freie Speicherplatz auf der Root-Festplatte Ihres Gateways weniger als 1 GB beträgt oder wenn innerhalb eines Intervalls von 1 Minute mehr als 100 Integritätsbenachrichtigungen generiert werden, wird möglicherweise ein DroppedNotifications Fehler anstelle der erwarteten CloudWatch Protokolleinträge angezeigt. Unter diesen Umständen generiert das Gateway vorsichtshalber CloudWatch keine detaillierten Protokollbenachrichtigungen mehr.
Um einen DroppedNotifications Fehler zu beheben
-
Prüfen Sie die
Root Disk UsageMetrik auf der Registerkarte Monitoring für Ihr Gateway in der Storage Gateway-Konsole, um festzustellen, ob der verfügbare Root-Festplattenspeicher knapp wird. -
Erhöhen Sie die Größe der Root-Speicherfestplatte des Gateways, wenn der verfügbare Speicherplatz weniger als 1 GB beträgt. Anweisungen finden Sie in der Dokumentation Ihres Hypervisors für virtuelle Maschinen.
Informationen zum Erhöhen der Root-Festplattengröße für Amazon EC2-Gateways finden Sie im Amazon Elastic Compute Cloud-Benutzerhandbuch unter Anfordern von Änderungen an Ihren EBS-Volumes.
Anmerkung
Es ist nicht möglich, die Root-Festplattengröße für die AWS Storage Gateway Hardware Appliance zu erhöhen.
-
Starten Sie Ihr Gateway neu.
Benachrichtigung: HardReboot
Sie können eine HardReboot-Benachrichtigung erhalten, wenn die Gateway-VM unerwartet neu gestartet wird. Ein solcher Neustart kann auf Stromausfall, einen Hardwarefehler oder ein anderes Ereignis zurückzuführen sein. Bei VMware-Gateways kann ein Reset durch vSphere High Availability Application Monitoring zu diesem Ereignis führen.
Wenn Ihr Gateway in einer solchen Umgebung ausgeführt wird, überprüfen Sie, ob die Benachrichtigung HealthCheckFailure vorhanden ist, und konsultieren Sie das VMware-Ereignisprotokoll für die VM.
Benachrichtigung: Reboot
Sie können eine Neustart-Benachrichtigung erhalten, wenn die Gateway-VM neu gestartet wird. Sie können eine Gateway-VM mithilfe der VM Hypervisor-Managementkonsole oder der Storage-Gateway-Konsole neu starten. Sie können den Neustart auch mithilfe der Gateway-Software während des Wartungszyklus des Gateways ausführen.
Wenn die Zeit des Neustarts innerhalb von 10 Minuten nach der konfigurierten Wartungsstartzeit des Gateways liegt, ist dieser Neustart wahrscheinlich ein normales Ereignis und kein Anzeichen für ein Problem. Wenn der Neustart deutlich außerhalb des Wartungsfensters stattgefunden hat, überprüfen Sie, ob das Gateway manuell neu gestartet wurde.
Problembehandlung: Probleme mit der Active Directory-Domäne
FSx File Gateway generiert keine spezifischen Protokollmeldungen für Probleme mit der Active Directory-Domäne. Wenn Sie Probleme haben, Ihr Gateway mit Ihrer Active Directory-Domäne zu verbinden, gehen Sie wie folgt vor:
-
Stellen Sie sicher, dass das Gateway nicht versucht, einen schreibgeschützten Domänencontroller (RODC) zu verwenden, um der Domäne beizutreten.
-
Stellen Sie sicher, dass das Gateway für die Verwendung der richtigen DNS-Server konfiguriert ist.
Wenn Sie beispielsweise versuchen, eine Amazon EC2-Gateway-Instance mit einem AWS verwalteten Active Directory zu verbinden, stellen Sie sicher, dass die für Ihre EC2-VPC festgelegte DHCP-Option die AWS verwalteten Active Directory-DNS-Server angibt.
DNS-Server, die Sie über den VPC-DHCP-Optionssatz konfigurieren, werden allen EC2-Instances in der VPC zur Verfügung gestellt. Wenn Sie einen DNS-Server für ein einzelnes Gateway angeben möchten, können Sie dies über die lokale EC2-Konsole dieses Gateways tun.
Für lokale Gateways geben Sie einen DNS-Server mithilfe der lokalen VM-Konsole an.
-
Überprüfen Sie die Gateway-Netzwerkkonnektivität, indem Sie die folgenden Befehle an der Befehlszeile in der lokalen Konsole des Gateways ausführen. Ersetzen Sie die hervorgehobenen Variablen durch den tatsächlichen Domänennamen und die IP-Adressen aus Ihrer Bereitstellung.
dig -dExampleDomainNamencport -dExampleDomainControllerIPAddress-p 445 ncport -dExampleDomainControllerIPAddress-p 389 -
Stellen Sie sicher, dass Ihr Active Directory-Dienstkonto über die erforderlichen Berechtigungen verfügt. Weitere Informationen finden Sie unter Berechtigungsanforderungen für das Active Directory-Dienstkonto.
-
Stellen Sie sicher, dass das Gateway der richtigen Organisationseinheit (OU) beitritt.
Durch den Beitritt zu einer Domäne wird ein Active Directory-Computerkonto im Standardcomputercontainer (der keine OU ist) erstellt, wobei die Gateway-ID des Gateways als Kontonamen verwendet wird (z. B. SGW-1234ADE). Es ist nicht möglich, den Namen dieses Kontos anzupassen.
Wenn Ihre Active Directory-Umgebung über eine eigene Organisationseinheit für neue Computerobjekte verfügt, müssen Sie diese Organisationseinheit angeben, wenn Sie der Domäne beitreten.
Wenn beim Versuch, der angegebenen Organisationseinheit beizutreten, Fehler beim Zugriff verweigert auftreten, wenden Sie sich an Ihren Active Directory-Domänenadministrator. Der Administrator muss möglicherweise das Computerkonto des Gateways vorab einrichten, bevor es der Domäne beitreten kann. Weitere Informationen finden Sie unter Wie kann ich Probleme beim Beitritt meines Storage Gateway-Datei-Gateways zu einer Domäne für die Microsoft Active Directory-Authentifizierung beheben?
. -
Stellen Sie sicher, dass der Hostname Ihres Gateways in DNS aufgelöst werden kann, indem Sie den folgenden Befehl an der Befehlszeile in der lokalen Konsole des Gateways ausführen. Ersetzen Sie die hervorgehobene Variable durch den tatsächlichen Hostnamen für Ihr Gateway.
dig -dExampleHostName-r AWenn Sie einen benutzerdefinierten Hostnamen für Ihr Gateway konfiguriert haben, müssen Sie manuell einen DNS hinzufügen A-record , der auf seine IP-Adresse verweist.
-
Stellen Sie sicher, dass die Netzwerklatenz zwischen dem Gateway und dem Domänencontroller angemessen niedrig ist. Bei der Anfrage zum Beitritt zu einer Domäne kann es zu einem Timeout kommen, wenn das Gateway nicht innerhalb von 20 Sekunden eine Antwort vom Domänencontroller erhält.
Wenn Sie das Gateway mithilfe des JoinDomain CLI-Befehls mit der Domäne verbinden, können Sie das
--timeout-in-secondsFlag hinzufügen, um den Timeout auf maximal 3.600 Sekunden zu erhöhen. -
Stellen Sie sicher, dass der Active Directory-Benutzer, den Sie für den Beitritt des Gateways zur Domäne verwenden, über die dafür erforderlichen Rechte verfügt.
Problembehandlung: Verwenden von CloudWatch Metriken
Im Folgenden finden Sie Informationen zu Maßnahmen zur Behebung von Problemen bei der Verwendung von CloudWatch Amazon-Metriken mit Storage Gateway.
Themen
Ihr Gateway reagiert langsam, wenn Sie Verzeichnisse durchsuchen
Wenn Ihr File Gateway langsam reagiert, wenn Sie den ls Befehl ausführen oder Verzeichnisse durchsuchen, überprüfen Sie die IndexEviction CloudWatch Messwerte IndexFetch und:
-
Wenn die
IndexFetchMetrik größer als 0 ist, wenn Sie einenlsBefehl ausführen oder Verzeichnisse durchsuchen, wurde Ihr File Gateway ohne Informationen über den Inhalt des betroffenen Verzeichnisses gestartet und musste auf FSx for Windows File Server zugreifen. Nachfolgende Versuche, den Inhalt dieses Verzeichnisses aufzulisten, sollten schneller ausgeführt werden. -
Wenn die
IndexEvictionMetrik größer als 0 ist, bedeutet dies, dass Ihr File Gateway die Grenze dessen erreicht hat, was es zu diesem Zeitpunkt in seinem Cache verwalten kann. In diesem Fall muss Ihr File Gateway Speicherplatz aus dem Verzeichnis freigeben, auf das zuletzt zugegriffen wurde, um ein neues Verzeichnis aufzulisten. Wenn dies häufig vorkommt und die Leistung beeinträchtigt wird, wenden Sie sich an Support.Diskutieren Sie mit Support dem Inhalt des zugehörigen Amazon FSx-Dateisystems und Empfehlungen zur Leistungsverbesserung auf der Grundlage Ihres Anwendungsfalls.
Ihr Gateway reagiert nicht
Wenn Ihr File Gateway nicht reagiert, gehen Sie wie folgt vor:
-
Wenn kürzlich ein Neustart oder ein Softwareupdate vorgenommen wurde, überprüfen Sie die Metrik
IOWaitPercent. Diese Metrik zeigt den Prozentsatz der Zeit an, in der sich die CPU im Leerlauf befindet, wenn eine ausstehende I/O Festplattenanforderung vorliegt. In einigen Fällen ist dieser Prozentsatz möglicherweise hoch (10 oder höher) und angestiegen, nachdem der Server neu gestartet oder aktualisiert wurde. In diesen Fällen wird Ihr File Gateway möglicherweise durch eine langsame Root-Festplatte überlastet, während es den Index-Cache in den Arbeitsspeicher umwandelt. Sie können dieses Problem beheben, indem Sie einen schnelleren physischen Datenträger für den Stamm-Datenträger verwenden. -
Wenn die
MemUsedBytesMetrik der Metrik entspricht oder fast mit derMemTotalBytesMetrik übereinstimmt, geht Ihrem File Gateway der verfügbare Arbeitsspeicher aus. Stellen Sie sicher, dass Ihr File Gateway mindestens über den erforderlichen Arbeitsspeicher verfügt. Wenn dies bereits der Fall ist, sollten Sie erwägen, Ihrem File Gateway je nach Arbeitslast und Anwendungsfall mehr RAM hinzuzufügen.Wenn die Dateifreigabe SMB ist, kann dieses Problem auch auf die Anzahl der SMB-Clients zurückzuführen sein, die mit der Dateifreigabe verbunden sind. Überprüfen Sie die Metrik
SMBV(1/2/3)Sessions, um die Anzahl der Clients zu sehen, die zu einem bestimmten Zeitpunkt verbunden sind. Wenn viele Clients angeschlossen sind, müssen Sie Ihrem File Gateway möglicherweise mehr RAM hinzufügen.
Sie sehen keine Dateien in Ihrem Amazon FSx-Dateisystem
Wenn Sie feststellen, dass Dateien auf dem Gateway nicht im Amazon FSx-Dateisystem wiedergegeben werden, überprüfen Sie die FilesFailingUpload Metrik. Wenn die Metrik meldet, dass einige Dateien nicht hochgeladen werden können, überprüfen Sie Ihre Statusbenachrichtigungen. Wenn Dateien nicht hochgeladen werden können, generiert das Gateway eine Statusmeldung mit weiteren Informationen zu dem Problem.
Sie sehen keine älteren Snapshots in Ihrem Amazon FSx-Dateisystem
Einige Dateivorgänge auf dem FSx File Gateway, wie z. B. Umbenennungen von Ordnern auf oberster Ebene oder Berechtigungsänderungen, können zu mehreren Dateivorgängen führen, die zu einer hohen I/O Belastung Ihres FSx for Windows File Server-Dateisystems führen. Wenn Ihr Dateisystem nicht über genügend Leistungsressourcen für Ihre Arbeitslast verfügt, löscht das Dateisystem möglicherweise Schattenkopien, da es der Verfügbarkeit von fortlaufenden I/O Schattenkopien Vorrang vor der Aufbewahrung historischer Schattenkopien einräumt.
Prüfen Sie in der Amazon FSx-Konsole auf der Seite Überwachung und Leistung, ob Ihr Dateisystem nicht ausreichend ausgestattet ist. Ist dies der Fall, können Sie auf SSD-Speicher umsteigen, die Durchsatzkapazität erhöhen oder SSD-IOPS erhöhen, um Ihre Arbeitslast zu bewältigen.
Ihr Gateway überträgt Daten langsam an Amazon FSx
Wenn Ihr File Gateway langsam Daten an Amazon FSx for Windows File Server überträgt, gehen Sie wie folgt vor:
-
Wenn die
CachePercentDirtyMetrik 80 oder höher ist, schreibt Ihr File Gateway Daten schneller auf die Festplatte, als es die Daten auf Amazon FSx for Windows File Server hochladen kann. Erwägen Sie, die Bandbreite für Uploads von Ihrem File Gateway zu erhöhen, eine oder mehrere Cache-Festplatten hinzuzufügen oder die Client-Schreibvorgänge zu verlangsamen oder die Durchsatzkapazität für den zugehörigen Amazon FSx for Windows File Server zu erhöhen. -
Wenn die
CachePercentDirtyMetrik niedrig ist, überprüfen Sie dieIoWaitPercentMetrik. Wenn der Wert größer als 10IoWaitPercentist, wird Ihr File Gateway möglicherweise durch die Geschwindigkeit der lokalen Cache-Festplatte überlastet. Wir empfehlen lokale SSD-Datenträger (Solid-State-Drive) für den Cache, vorzugsweise NVM Express (NVMe). Wenn solche Datenträger nicht verfügbar sind, verwenden Sie mehrere Cache-Datenträger von separaten physischen Datenträgern, um zu versuchen, die Leistung zu verbessern.
Ihr Gateway-Backup-Job schlägt fehl oder es treten Fehler beim Schreiben auf Ihr Gateway auf
Wenn Ihr File Gateway-Backup-Job fehlschlägt oder beim Schreiben auf Ihr File Gateway Fehler auftreten, gehen Sie wie folgt vor:
-
Wenn die
CachePercentDirtyMetrik 90 Prozent oder mehr beträgt, kann Ihr File Gateway keine neuen Schreibvorgänge auf die Festplatte akzeptieren, da nicht genügend Speicherplatz auf der Cache-Festplatte verfügbar ist. Um zu sehen, wie schnell Ihr File Gateway auf FSx for Windows File Server hochlädt, sehen Sie sich dieCloudBytesUploadedMetrik an. Vergleichen Sie diese Metrik mit derWriteBytesMetrik, die zeigt, wie schnell der Client Dateien auf Ihr File Gateway schreibt. Wenn der SMB-Client schneller auf Ihr File Gateway schreibt, als er auf FSx for Windows File Server hochladen kann, fügen Sie mehr Cache-Festplatten hinzu, um mindestens die Größe des Backup-Jobs abzudecken. Oder erhöhen Sie die Upload-Bandbreite. -
Wenn eine große Dateikopie, z. B. ein Backup-Job, fehlschlägt, der
CachePercentDirtyMesswert jedoch unter 80 Prozent liegt, erreicht Ihr File Gateway möglicherweise einen clientseitigen Sitzungstimeout. Für SMB können Sie diesen Timeout mit dem Befehl erhöhen. PowerShellSet-SmbClientConfiguration -SessionTimeout 300Wenn Sie diesen Befehl ausführen, wird das Timeout auf 300 Sekunden festgelegt.